Intial import

This commit is contained in:
Nicolas Chauvet 2008-05-10 07:41:32 +00:00
parent 02d249a864
commit 3c392b63ee
4 changed files with 190 additions and 0 deletions

View File

@ -0,0 +1 @@
openexr_viewers-1.0.1.tar.gz

133
OpenEXR_Viewers.spec Normal file
View File

@ -0,0 +1,133 @@
# nVidia Cg toolkit is not free
%define with_Cg 0
%if %with_Cg
%define real_name OpenEXR_Viewers-nonfree
%define V_suffix -nonfree
%define priority 10
%else
%define real_name OpenEXR_Viewers
%define V_suffix -fedora
%define priority 5
%endif
Name: %{real_name}
Version: 1.0.1
Release: 1%{?dist}
Summary: Viewers programs for OpenEXR
Group: Applications/Multimedia
License: AMPAS BSD
URL: http://www.openexr.com
Source0: http://download.savannah.nongnu.org/releases/openexr/openexr_viewers-%{version}.tar.gz
Patch0: openexr_viewers-1.0.1-gcc43.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: OpenEXR_CTL-devel
BuildRequires: OpenEXR_CTL
BuildRequires: fltk-devel
%if %with_Cg
BuildRequires: Cg
BuildRequires: freeglut-devel
Provides: OpenEXR_Viewers = %{version}
%else
BuildConflicts: Cg
%endif
# Last version was in F-7 - Can be dropped in F-10
Obsoletes: OpenEXR-utils < 1.6.0
Requires: OpenEXR_CTL
Requires(post): /usr/sbin/alternatives
Requires(preun): /usr/sbin/alternatives
%description
exrdisplay is a simple still image viewer that optionally applies color
transforms to OpenEXR images, using ctl as explained in this document:
doc/OpenEXRViewers.pdf
%if %with_Cg
playexr is a program that plays back OpenEXR image sequences, optionally
with CTL support, applying rendering and display transforms in line with
the current discussions at the AMPAS Image Interchange Framework committee
(September 2006).
This is the nonfree version compiled with nVidia Cg support
See: http://developer.nvidia.com/object/cg_toolkit.html
%else
%package docs
Summary: Documentation for %{name}
Group: Documentation
%description docs
This package contains documentation files for %{name}.
%endif
%prep
%setup -q -n openexr_viewers-%{version}
%patch0 -p1 -b .gcc43
%build
export CXXFLAGS="$RPM_OPT_FLAGS -L%{_libdir}"
%configure --disable-static \
%if %with_Cg
--with-cg-prefix=%{_prefix}
%endif
# Missing libs for playexr
sed -i -e 's|LIBS =|LIBS = -lglut|' playexr/Makefile
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
# Remove the config.h - uneeded afaik
rm -rf $RPM_BUILD_ROOT%{_includedir}
# move the binary
mv $RPM_BUILD_ROOT%{_bindir}/exrdisplay $RPM_BUILD_ROOT%{_bindir}/exrdisplay%{V_suffix}
# Removing installed docs
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
# Owernship of the alternative provides
touch $RPM_BUILD_ROOT%{_bindir}/exrdisplay
%clean
rm -rf $RPM_BUILD_ROOT
%post
alternatives --install %{_bindir}/exrdisplay exrdisplay %{_bindir}/exrdisplay%{V_suffix} %{priority} ||:
%preun
if [ $1 -eq 0 ]; then
alternatives --remove exrdisplay %{_bindir}/exrdisplay%{V_suffix} || :
fi
%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README
%ghost %{_bindir}/exrdisplay
%{_bindir}/exrdisplay%{V_suffix}
%if %with_Cg
%{_bindir}/playexr
%else
%files docs
%defattr(-,root,root,-)
%doc doc/OpenEXRViewers.odt doc/OpenEXRViewers.pdf
%endif
%changelog
* Sat May 10 2008 kwizart < kwizart at gmail.com > - 1.0.1-2
- Ghost the alternative provides
- Obsoletes OpenEXR-utils
* Wed Jan 9 2008 kwizart < kwizart at gmail.com > - 1.0.1-1
- Initial package for Fedora

View File

@ -0,0 +1,55 @@
diff -up openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 openexr_viewers-1.0.1/exrdisplay/applyCtl.h
--- openexr_viewers-1.0.1/exrdisplay/applyCtl.h.gcc43 2006-12-09 01:14:07.000000000 +0100
+++ openexr_viewers-1.0.1/exrdisplay/applyCtl.h 2008-01-10 02:07:14.000000000 +0100
@@ -49,6 +49,7 @@
#include <ImfArray.h>
#include <ImfHeader.h>
#include <vector>
+#include <cstdlib>
//
// Apply a series of CTL transforms to the raw pixel data from an image file
diff -up openexr_viewers-1.0.1/configure.ac.gcc43 openexr_viewers-1.0.1/configure.ac
--- openexr_viewers-1.0.1/configure.ac.gcc43 2007-10-10 00:20:51.000000000 +0200
+++ openexr_viewers-1.0.1/configure.ac 2008-01-10 02:07:14.000000000 +0100
@@ -126,6 +126,7 @@ AM_COMPILELINKRUN(
#include <ImfFrameBuffer.h>
#include <ImathBox.h>
#include <vector>
+#include <cstdlib>
using namespace Ctl;
using namespace Imf;
using namespace Imath;
diff -up openexr_viewers-1.0.1/configure.gcc43 openexr_viewers-1.0.1/configure
--- openexr_viewers-1.0.1/configure.gcc43 2007-10-10 00:21:01.000000000 +0200
+++ openexr_viewers-1.0.1/configure 2008-01-10 02:07:14.000000000 +0100
@@ -20869,6 +20869,7 @@ cat >>conftest.$ac_ext <<_ACEOF
#include <ImfFrameBuffer.h>
#include <ImathBox.h>
#include <vector>
+#include <cstdlib>
using namespace Ctl;
using namespace Imf;
using namespace Imath;
diff -up openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 openexr_viewers-1.0.1/playexr/ctlToLut.h
--- openexr_viewers-1.0.1/playexr/ctlToLut.h.gcc43 2008-01-10 03:09:55.000000000 +0100
+++ openexr_viewers-1.0.1/playexr/ctlToLut.h 2008-01-10 03:11:18.000000000 +0100
@@ -88,6 +88,7 @@
#include <string>
#include <vector>
#include <half.h>
+#include <cstdlib>
void
diff -up openexr_viewers-1.0.1/playexr/main.cpp.gcc43 openexr_viewers-1.0.1/playexr/main.cpp
--- openexr_viewers-1.0.1/playexr/main.cpp.gcc43 2008-01-10 03:05:03.000000000 +0100
+++ openexr_viewers-1.0.1/playexr/main.cpp 2008-01-10 03:05:48.000000000 +0100
@@ -48,6 +48,7 @@
#include <vector>
#include <string>
#include <stdlib.h>
+#include <cstring>
using namespace std;

View File

@ -0,0 +1 @@
e7b77c320a00cd89ef50605ba2a374cd openexr_viewers-1.0.1.tar.gz