Add install patch.

This commit is contained in:
Richard Shaw 2021-08-23 07:45:53 -05:00
parent 5f39649d11
commit eb976f8069
1 changed files with 15 additions and 0 deletions

15
ocio-install.patch Normal file
View File

@ -0,0 +1,15 @@
Index: OpenColorIO-2.0.1/src/OpenColorIO/CMakeLists.txt
===================================================================
--- OpenColorIO-2.0.1.orig/src/OpenColorIO/CMakeLists.txt
+++ OpenColorIO-2.0.1/src/OpenColorIO/CMakeLists.txt
@@ -279,7 +279,7 @@ if(MSVC AND BUILD_SHARED_LIBS)
endif()
install(TARGETS OpenColorIO
- LIBRARY DESTINATION lib
- RUNTIME DESTINATION bin
- ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)