Update to latest upstream release.

This commit is contained in:
Richard M. Shaw 2014-01-13 12:41:38 -06:00
parent 0e4683a0ca
commit d7bf8f2205
2 changed files with 2 additions and 27 deletions

View File

@ -1,24 +0,0 @@
diff -Naur OpenColorIO-1.0.9.orig/CMakeLists.txt OpenColorIO-1.0.9/CMakeLists.txt
--- OpenColorIO-1.0.9.orig/CMakeLists.txt 2013-10-08 17:59:34.000000000 -0500
+++ OpenColorIO-1.0.9/CMakeLists.txt 2013-11-05 21:20:11.824239166 -0600
@@ -190,7 +190,7 @@
# Set minimum yaml version for non-patched sources.
set(YAML_VERSION_MIN "0.3.0")
include(FindPkgConfig)
- pkg_check_modules(YAML_CPP yaml-cpp)
+ pkg_search_module(YAML_CPP yaml-cpp yaml-cpp03)
if(YAML_CPP_FOUND)
if(YAML_CPP_VERSION VERSION_EQUAL ${YAML_VERSION_MIN} OR
YAML_CPP_VERSION VERSION_GREATER ${YAML_VERSION_MIN})
diff -Naur OpenColorIO-1.0.9.orig/src/core/OCIOYaml.h OpenColorIO-1.0.9/src/core/OCIOYaml.h
--- OpenColorIO-1.0.9.orig/src/core/OCIOYaml.h 2013-10-08 17:59:34.000000000 -0500
+++ OpenColorIO-1.0.9/src/core/OCIOYaml.h 2013-11-05 21:19:23.989303122 -0600
@@ -68,7 +68,7 @@
#endif
-#include <yaml-cpp/yaml.h>
+#include <yaml-cpp03/yaml.h>
#ifndef INCLUDED_OCIO_YAML_H
#define INCLUDED_OCIO_YAML_H

View File

@ -17,9 +17,8 @@ Summary: Enables color transforms and image display across graphics apps
License: BSD
URL: http://opencolorio.org/
# Github archive was generated on the fly using the following URL:
# https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
# https://github.com/imageworks/OpenColorIO/tarball/v1.0.9
Source0: %{name}-%{version}.tar.gz
Patch0: OpenColorIO-yaml_cpp3.patch
# Utilities
%if 0%{?el6}
@ -43,7 +42,7 @@ BuildRequires: zlib-devel
#######################
BuildRequires: tinyxml-devel
BuildRequires: lcms2-devel
BuildRequires: yaml-cpp03-devel >= 0.3.0
BuildRequires: yaml-cpp-devel >= 0.3.0
# The following bundled projects are only used for document generation.
#BuildRequires: python-docutils