Rebuild against yaml-cpp03 compatibility package.

This commit is contained in:
Richard M. Shaw 2013-10-31 09:36:16 -05:00
parent 85ad79a2b8
commit 8b16cda5c2
2 changed files with 38 additions and 2 deletions

View File

@ -0,0 +1,31 @@
diff -Naur OpenColorIO-1.0.8.orig/CMakeLists.txt OpenColorIO-1.0.8/CMakeLists.txt
--- OpenColorIO-1.0.8.orig/CMakeLists.txt 2013-10-16 14:19:36.186578444 -0500
+++ OpenColorIO-1.0.8/CMakeLists.txt 2013-10-16 14:20:03.469002840 -0500
@@ -193,7 +193,7 @@
set(YAML_VERSION_MIN "0.3.0")
include(FindPkgConfig)
if(PKG_CONFIG_EXECUTABLE)
- pkg_check_modules(YAML_CPP yaml-cpp)
+ pkg_search_module(YAML_CPP yaml-cpp yaml-cpp3)
else(PKG_CONFIG_EXECUTABLE)
find_package(YAML_CPP)
endif(PKG_CONFIG_EXECUTABLE)
@@ -416,4 +416,4 @@
COMMENT "Running ctest with verbose output")
# Log CMake first run done
-SET(CMAKE_FIRST_RUN 0 CACHE INTERNAL "")
\ No newline at end of file
+SET(CMAKE_FIRST_RUN 0 CACHE INTERNAL "")
diff -Naur OpenColorIO-1.0.8.orig/src/core/OCIOYaml.h OpenColorIO-1.0.8/src/core/OCIOYaml.h
--- OpenColorIO-1.0.8.orig/src/core/OCIOYaml.h 2012-12-11 17:21:23.000000000 -0600
+++ OpenColorIO-1.0.8/src/core/OCIOYaml.h 2013-10-16 14:21:51.888715333 -0500
@@ -68,7 +68,7 @@
#endif
-#include <yaml-cpp/yaml.h>
+#include <yaml-cpp3/yaml.h>
#ifndef INCLUDED_OCIO_YAML_H
#define INCLUDED_OCIO_YAML_H

View File

@ -11,7 +11,7 @@
Name: OpenColorIO
Version: 1.0.8
Release: 5%{?dist}
Release: 6%{?dist}
Summary: Enables color transforms and image display across graphics apps
License: BSD
@ -20,6 +20,7 @@ URL: http://opencolorio.org/
# https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
Source0: %{name}-%{version}.tar.gz
Patch0: OpenColorIO-pull_300.patch
Patch1: OpenColorIO-yaml_cpp3.patch
# Utilities
%if 0%{?el6}
@ -81,6 +82,7 @@ Development libraries and headers for %{name}.
%prep
%setup -q
%patch0 -p1 -b .pull300
%patch1 -p1 -b .yaml3
# Remove what bundled libraries
rm -f ext/lcms*
@ -107,7 +109,7 @@ make %{?_smp_mflags}
%install
pushd build
make install DESTDIR=%{buildroot}
%make_install
# Generate man pages
mkdir -p %{buildroot}%{_mandir}/man1
@ -153,6 +155,9 @@ mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
%changelog
* Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
- Rebuild against yaml-cpp03 compatibility package.
* Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
- Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264