Another fix for the cmake version in EL6.

This commit is contained in:
Richard M. Shaw 2012-05-04 15:02:53 -05:00
parent ee32f47b3c
commit 7d594e5efd
2 changed files with 15 additions and 0 deletions

View File

@ -0,0 +1,11 @@
diff -Naur imageworks-OpenColorIO-b3cb224.orig/src/apps/ociocheck/CMakeLists.txt imageworks-OpenColorIO-b3cb224/src/apps/ociocheck/CMakeLists.txt
--- imageworks-OpenColorIO-b3cb224.orig/src/apps/ociocheck/CMakeLists.txt 2012-04-17 19:08:16.000000000 -0500
+++ imageworks-OpenColorIO-b3cb224/src/apps/ociocheck/CMakeLists.txt 2012-05-04 15:00:26.292732699 -0500
@@ -12,6 +12,7 @@
target_link_libraries(ociocheck
OpenColorIO
+ ${YAML_CPP_LIBRARIES}
)
install(TARGETS ociocheck DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)

View File

@ -20,6 +20,7 @@ Source0: imageworks-%{name}-v%{version}-0-%{githash1}.tar.gz
Patch0: OpenColorIO-1.0.7-pylib_no_soname.patch
Patch1: OpenColorIO-1.0.7-docfix.patch
Patch2: OpenColorIO-1.0.7-link-yaml_cpp.patch
# Utilities
BuildRequires: cmake
@ -80,6 +81,9 @@ Development libraries and headers for %{name}.
%patch0 -p1 -b .pylib
# Exclude hidden files from being packaged.
%patch1 -p1 -b .docfix
# Fix for proper linking with cmake 2.6.
%patch2 -p1 -b .link_yaml
# Remove what bundled libraries
rm -f ext/lcms*