- nm: fixes for ZTE/Onda modem detection

- nm: prevent re-opening serial port when the SIM has a PIN
- applet: updated translations
- editor: show list column headers
Thu Jun 25 2009 Dan Williams <dcbw@redhat.com> - 0.7.1-6.git20090617
- nm: fix serial port settings
Wed Jun 17 2009 Dan Williams <dcbw@redhat.com> - 0.7.1-5.git20090617
- nm: fix AT&T Quicksilver modem connections (rh #502002)
- nm: fix support for s390 bus types (rh #496820)
- nm: fix detection of some CMOtech modems
- nm: handle unsolicited wifi scans better
- nm: resolv.conf fixes when using DHCP and overriding search domains
- nm: handle WEP and WPA passphrases (rh #441070)
- nm: fix removal of old APs when none are scanned
- nm: fix Huawei EC121 and EC168C detection and handling (rh #496426)
- applet: save WEP and WPA passphrases instead of hashed keys (rh #441070)
- applet: fix broken notification bubble actions
- applet: default to WEP encryption for Ad-Hoc network creation
- applet: fix crash when connection editor dialogs are canceled
- applet: add a mobile broadband provider wizard
Tue May 19 2009 Karsten Hopp <karsten@redhat.com> 0.7.1-4.git20090414.1
- drop ExcludeArch s390 s390x, we need at least the header files
0.7.1-4.git20090414
- nm-save-the-leases.patch: Use per-connection lease files, and don't
    delete them on interface deactivate.
This commit is contained in:
Daniel Williams 2009-07-08 17:38:51 +00:00
parent 491e6da313
commit e7172c74a8
4 changed files with 48 additions and 112 deletions

View File

@ -1,7 +1,5 @@
%define udev_scriptdir /lib/udev
ExcludeArch: s390 s390x
%define dbus_version 1.1
%define dbus_glib_version 0.73-6
%define hal_version 0.5.0
@ -11,14 +9,14 @@ ExcludeArch: s390 s390x
%define libnl_version 1.1
%define ppp_version 2.2.4
%define snapshot .git20090414
%define applet_snapshot %{nil}
%define snapshot .git20090708
%define applet_snapshot .git20090708
Name: NetworkManager
Summary: Network connection manager and user applications
Epoch: 1
Version: 0.7.1
Release: 3%{snapshot}%{?dist}
Release: 7%{snapshot}%{?dist}
Group: System Environment/Base
License: GPLv2+
URL: http://www.gnome.org/projects/NetworkManager/
@ -28,7 +26,6 @@ Source1: network-manager-applet-%{version}%{applet_snapshot}.tar.bz2
Source2: nm-system-settings.conf
Patch1: nm-applet-internal-buildfixes.patch
Patch2: explain-dns1-dns2.patch
Patch3: ifcfg-rh-inotify-update-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
PreReq: chkconfig
@ -36,14 +33,15 @@ Requires: dbus >= %{dbus_version}
Requires: dbus-glib >= %{dbus_glib_version}
Requires: hal >= %{hal_version}
Requires: iproute
Requires: dhclient >= 3.0.2-12
Requires: wpa_supplicant >= 0.5.7-21
Requires: dhclient >= 12:4.1.0
Requires: wpa_supplicant >= 1:0.6.8-4
Requires: libnl >= %{libnl_version}
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
Requires: ppp >= %{ppp_version}
Requires: avahi-autoipd
Requires: dnsmasq
Requires: udev
Requires: mobile-broadband-provider-info >= 0.20090602
Obsoletes: dhcdbd
Conflicts: NetworkManager-vpnc < 1:0.7.0.99-1
@ -145,9 +143,9 @@ NetworkManager functionality from applications that use glib.
# unpack the applet
tar -xjf %{SOURCE1}
%patch1 -p1 -b .buildfix
%patch2 -p1 -b .explain-dns1-dns2
%patch3 -p1 -b .ifcfg-rh-inotify-fix
%build
@ -281,7 +279,7 @@ fi
%{_libdir}/pppd/2.4.4/nm-pppd-plugin.so
%{_datadir}/PolicyKit/policy/*.policy
%{udev_scriptdir}/nm-modem-probe
%{udev_scriptdir}/rules.d/77-nm-probe-modem-capabilities.rules
%{udev_scriptdir}/rules.d/*.rules
%files devel
%defattr(-,root,root,0755)
@ -328,6 +326,37 @@ fi
%{_datadir}/gtk-doc/html/libnm-util/*
%changelog
* Wed Jul 8 2009 Dan Williams <dcbw@redhat.com> - 0.7.1-7.git20090708
- nm: fixes for ZTE/Onda modem detection
- nm: prevent re-opening serial port when the SIM has a PIN
- applet: updated translations
- editor: show list column headers
* Thu Jun 25 2009 Dan Williams <dcbw@redhat.com> - 0.7.1-6.git20090617
- nm: fix serial port settings
* Wed Jun 17 2009 Dan Williams <dcbw@redhat.com> - 0.7.1-5.git20090617
- nm: fix AT&T Quicksilver modem connections (rh #502002)
- nm: fix support for s390 bus types (rh #496820)
- nm: fix detection of some CMOtech modems
- nm: handle unsolicited wifi scans better
- nm: resolv.conf fixes when using DHCP and overriding search domains
- nm: handle WEP and WPA passphrases (rh #441070)
- nm: fix removal of old APs when none are scanned
- nm: fix Huawei EC121 and EC168C detection and handling (rh #496426)
- applet: save WEP and WPA passphrases instead of hashed keys (rh #441070)
- applet: fix broken notification bubble actions
- applet: default to WEP encryption for Ad-Hoc network creation
- applet: fix crash when connection editor dialogs are canceled
- applet: add a mobile broadband provider wizard
* Tue May 19 2009 Karsten Hopp <karsten@redhat.com> 0.7.1-4.git20090414.1
- drop ExcludeArch s390 s390x, we need at least the header files
* Tue May 05 2009 Adam Jackson <ajax@redhat.com> 1:0.7.1-4.git20090414
- nm-save-the-leases.patch: Use per-connection lease files, and don't delete
them on interface deactivate.
* Thu Apr 16 2009 Dan Williams <dcbw@redhat.com> - 1:0.7.1-3.git20090414
- ifcfg-rh: fix problems noticing changes via inotify (rh #495884)

View File

@ -1,92 +0,0 @@
diff --git a/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.c b/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.c
index 7e18ed0..bfc36af 100644
--- a/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.c
+++ b/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.c
@@ -317,27 +317,27 @@ nm_ifcfg_connection_get_unmanaged (NMIfcfgConnection *self)
return NM_IFCFG_CONNECTION_GET_PRIVATE (self)->unmanaged;
}
-static gboolean
-update (NMExportedConnection *exported, GHashTable *new_settings, GError **error)
+gboolean
+nm_ifcfg_connection_update (NMIfcfgConnection *self, GHashTable *new_settings, GError **error)
{
+ NMExportedConnection *exported = NM_EXPORTED_CONNECTION (self);
NMIfcfgConnectionPrivate *priv = NM_IFCFG_CONNECTION_GET_PRIVATE (exported);
- gboolean success;
NMConnection *connection;
- success = NM_EXPORTED_CONNECTION_CLASS (nm_ifcfg_connection_parent_class)->update (exported, new_settings, error);
- if (success) {
- connection = nm_exported_connection_get_connection (exported);
- success = nm_connection_replace_settings (connection, new_settings, error);
- if (success) {
- success = writer_update_connection (connection,
- IFCFG_DIR,
- priv->filename,
- priv->keyfile,
- error);
- }
- }
+ connection = nm_exported_connection_get_connection (exported);
+ if (!nm_connection_replace_settings (connection, new_settings, error))
+ return FALSE;
+
+ return writer_update_connection (connection, IFCFG_DIR, priv->filename, priv->keyfile, error);
+}
+
+static gboolean
+update (NMExportedConnection *exported, GHashTable *new_settings, GError **error)
+{
+ if (!NM_EXPORTED_CONNECTION_CLASS (nm_ifcfg_connection_parent_class)->update (exported, new_settings, error))
+ return FALSE;
- return success;
+ return nm_ifcfg_connection_update (NM_IFCFG_CONNECTION (exported), new_settings, error);
}
static gboolean
diff --git a/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.h b/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.h
index f2a8c6d..dc13aa6 100644
--- a/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.h
+++ b/system-settings/plugins/ifcfg-rh/nm-ifcfg-connection.h
@@ -60,6 +60,10 @@ const char *nm_ifcfg_connection_get_udi (NMIfcfgConnection *self);
gboolean nm_ifcfg_connection_get_unmanaged (NMIfcfgConnection *self);
+gboolean nm_ifcfg_connection_update (NMIfcfgConnection *self,
+ GHashTable *new_settings,
+ GError **error);
+
G_END_DECLS
#endif /* NM_IFCFG_CONNECTION_H */
diff --git a/system-settings/plugins/ifcfg-rh/plugin.c b/system-settings/plugins/ifcfg-rh/plugin.c
index 25d93b9..976090c 100644
--- a/system-settings/plugins/ifcfg-rh/plugin.c
+++ b/system-settings/plugins/ifcfg-rh/plugin.c
@@ -293,9 +293,9 @@ connection_changed_handler (SCPluginIfcfg *plugin,
/* errors reading connection; remove it */
if (!ignore_error) {
PLUGIN_WARN (IFCFG_PLUGIN_NAME, " error: %s",
- error->message ? error->message : "(unknown)");
+ (error && error->message) ? error->message : "(unknown)");
}
- g_error_free (error);
+ g_clear_error (&error);
PLUGIN_PRINT (IFCFG_PLUGIN_NAME, "removed %s.", path);
*do_remove = TRUE;
@@ -336,7 +336,11 @@ connection_changed_handler (SCPluginIfcfg *plugin,
/* Only update if different */
if (!nm_connection_compare (new_wrapped, old_wrapped, NM_SETTING_COMPARE_FLAG_EXACT)) {
settings = nm_connection_to_hash (new_wrapped);
- nm_exported_connection_update (NM_EXPORTED_CONNECTION (connection), settings, NULL);
+ if (!nm_ifcfg_connection_update (connection, settings, &error)) {
+ PLUGIN_WARN (IFCFG_PLUGIN_NAME, " error updating: %s",
+ (error && error->message) ? error->message : "(unknown)");
+ g_clear_error (&error);
+ }
g_hash_table_destroy (settings);
}

View File

@ -3,20 +3,19 @@ diff -up NetworkManager-0.7.1/network-manager-applet-0.7.1/configure.ac.buildfix
+++ NetworkManager-0.7.1/network-manager-applet-0.7.1/configure.ac 2009-04-05 08:31:12.000000000 -0400
@@ -68,10 +68,6 @@ PKG_CHECK_MODULES(GOBJECT, gobject-2.0)
PKG_CHECK_MODULES(NMA,
[dbus-glib-1 >= 0.72
[dbus-glib-1 >= 0.74
glib-2.0 >= 2.10
- NetworkManager >= 0.7.0
- libnm_glib >= 0.7.0
- libnm-util >= 0.7.0
- libnm_glib_vpn >= 0.7.0
gtk+-2.0 >= 2.10
- NetworkManager >= 0.7.1
- libnm_glib >= 0.7.1
- libnm-util >= 0.7.1
- libnm_glib_vpn >= 0.7.1
gtk+-2.0 >= 2.14
libglade-2.0
gmodule-export-2.0
diff -up NetworkManager-0.7.1/network-manager-applet-0.7.1/src/connection-editor/Makefile.am.buildfix NetworkManager-0.7.1/network-manager-applet-0.7.1/src/connection-editor/Makefile.am
--- NetworkManager-0.7.1/network-manager-applet-0.7.1/src/connection-editor/Makefile.am.buildfix 2009-04-03 09:30:25.000000000 -0400
+++ NetworkManager-0.7.1/network-manager-applet-0.7.1/src/connection-editor/Makefile.am 2009-04-05 08:31:12.000000000 -0400
@@ -2,6 +2,10 @@ NULL=
@@ -1,5 +1,9 @@
bin_PROGRAMS = nm-connection-editor
+INCLUDES = -I${top_srcdir}/../include \

View File

@ -1,2 +1,2 @@
d90a997e3e2051ce8866fe24f765141f network-manager-applet-0.7.1.tar.bz2
656728d3decf12e75814b0f4e252929e NetworkManager-0.7.1.git20090414.tar.bz2
f361c757fda787a2a90719b9ae668702 NetworkManager-0.7.1.git20090708.tar.bz2
801d31708a175d2133edc66007667d71 network-manager-applet-0.7.1.git20090708.tar.bz2