Split applet/editor/libnm-gtk out to separate RPMS
This commit is contained in:
parent
2a5adcbd65
commit
cf9d329f24
10
.gitignore
vendored
10
.gitignore
vendored
@ -266,3 +266,13 @@ network-manager-applet-0.8.1.tar.bz2
|
||||
/network-manager-applet-0.9.1.90.git20110927.tar.bz2
|
||||
/NetworkManager-0.9.2.0.tar.bz2
|
||||
/network-manager-applet-0.9.2.0.tar.bz2
|
||||
/NetworkManager-0.9.3.0.git20120215.tar.bz2
|
||||
/network-manager-applet-0.9.3.0.git20120215.tar.bz2
|
||||
/NetworkManager-0.9.3.995.git20120302.tar.bz2
|
||||
/network-manager-applet-0.9.3.995.git20120302.tar.bz2
|
||||
/NetworkManager-0.9.3.995.git20120313.tar.bz2
|
||||
/network-manager-applet-0.9.3.995.git20120313.tar.bz2
|
||||
/NetworkManager-0.9.3.995.git20120314.tar.bz2
|
||||
/network-manager-applet-0.9.3.995.git20120314.tar.bz2
|
||||
/NetworkManager-0.9.3.997.tar.bz2
|
||||
/network-manager-applet-0.9.3.997.tar.bz2
|
||||
|
@ -7,11 +7,11 @@
|
||||
%define libnl3_version 3.2.6
|
||||
%define ppp_version 2.4.5
|
||||
|
||||
%define snapshot .git20120314
|
||||
%define applet_snapshot .git20120314
|
||||
%define realversion 0.9.3.995
|
||||
%define snapshot %{nil}
|
||||
%define applet_snapshot %{nil}
|
||||
%define realversion 0.9.3.997
|
||||
|
||||
%if 0%{?fedora} < 17
|
||||
%if 0%{?fedora} < 19
|
||||
%define systemd_dir /lib/systemd/system
|
||||
%else
|
||||
%define systemd_dir %{_prefix}/lib/systemd/system
|
||||
@ -20,22 +20,17 @@
|
||||
Name: NetworkManager
|
||||
Summary: Network connection manager and user applications
|
||||
Epoch: 1
|
||||
Version: 0.9.3.995
|
||||
Release: 0.6%{snapshot}%{?dist}
|
||||
Version: 0.9.3.997
|
||||
Release: 1%{snapshot}%{?dist}
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
|
||||
Source: %{name}-%{realversion}%{snapshot}.tar.bz2
|
||||
Source1: network-manager-applet-%{realversion}%{applet_snapshot}.tar.bz2
|
||||
Source2: NetworkManager.conf
|
||||
Patch1: nm-applet-internal-buildfixes.patch
|
||||
Patch2: explain-dns1-dns2.patch
|
||||
Patch3: nm-applet-no-notifications.patch
|
||||
Patch4: nm-polkit-permissive.patch
|
||||
Patch5: nm-applet-wifi-dialog-ui-fixes.patch
|
||||
Patch6: nss-error.patch
|
||||
Patch7: applet-ignore-deprecated.patch
|
||||
Source1: NetworkManager.conf
|
||||
Patch1: explain-dns1-dns2.patch
|
||||
Patch2: nm-polkit-permissive.patch
|
||||
Patch3: nss-error.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Requires(post): chkconfig
|
||||
@ -99,7 +94,7 @@ BuildRequires: wimax-devel
|
||||
BuildRequires: gnome-bluetooth-libs-devel >= 2.27.7.1-1
|
||||
%endif
|
||||
BuildRequires: systemd systemd-devel
|
||||
%if 0%{?fedora} < 17
|
||||
%if 0%{?fedora} < 19
|
||||
# systemd.pc is in systemd-units for F16 and below
|
||||
BuildRequires: systemd-units
|
||||
%endif
|
||||
@ -138,25 +133,6 @@ This package contains various headers accessing some NetworkManager functionalit
|
||||
from applications.
|
||||
|
||||
|
||||
%package gnome
|
||||
Summary: GNOME applications for use with NetworkManager
|
||||
Group: Applications/Internet
|
||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-gtk = %{epoch}:%{version}-%{release}
|
||||
Requires: dbus >= %{dbus_version}
|
||||
Requires: dbus-glib >= %{dbus_glib_version}
|
||||
Requires: libnotify >= 0.4.3
|
||||
Requires: gnome-keyring
|
||||
Requires: nss >= 3.11.7
|
||||
Requires: gnome-icon-theme
|
||||
Requires(post): /usr/bin/gtk-update-icon-cache
|
||||
|
||||
%description gnome
|
||||
This package contains GNOME utilities and applications for use with
|
||||
NetworkManager, including a panel applet for wireless networks.
|
||||
|
||||
|
||||
%package glib
|
||||
Summary: Libraries for adding NetworkManager support to applications that use glib.
|
||||
Group: Development/Libraries
|
||||
@ -182,42 +158,12 @@ This package contains the header and pkg-config files for development applicatio
|
||||
NetworkManager functionality from applications that use glib.
|
||||
|
||||
|
||||
%package gtk
|
||||
Summary: Private libraries for NetworkManager GUI support
|
||||
Group: Development/Libraries
|
||||
Requires: gtk3 >= %{gtk3_version}
|
||||
|
||||
%description gtk
|
||||
This package contains private libraries to be used only by nm-applet and
|
||||
the GNOME Control Center.
|
||||
|
||||
|
||||
%package gtk-devel
|
||||
Summary: Private header files for NetworkManager GUI support
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-devel = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-glib = %{epoch}:%{version}-%{release}
|
||||
Requires: gtk3-devel
|
||||
Requires: pkgconfig
|
||||
|
||||
%description gtk-devel
|
||||
This package contains private header and pkg-config files to be used only by
|
||||
nm-applet and the GNOME control center.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n NetworkManager-%{realversion}
|
||||
|
||||
# unpack the applet and nmcli
|
||||
tar -xjf %{SOURCE1}
|
||||
|
||||
%patch1 -p1 -b .buildfix
|
||||
%patch2 -p1 -b .explain-dns1-dns2
|
||||
%patch3 -p1 -b .no-notifications
|
||||
%patch4 -p1 -b .polkit-permissive
|
||||
%patch5 -p1 -b .applet-wifi-ui
|
||||
%patch6 -p1 -b .nss-error
|
||||
%patch7 -p1 -b .no-deprecated
|
||||
%patch1 -p1 -b .explain-dns1-dns2
|
||||
%patch2 -p1 -b .polkit-permissive
|
||||
%patch3 -p1 -b .nss-error
|
||||
|
||||
%build
|
||||
|
||||
@ -247,30 +193,13 @@ intltoolize --force
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
# build the applet
|
||||
pushd network-manager-applet-%{realversion}
|
||||
autoreconf -i
|
||||
intltoolize --force
|
||||
%configure \
|
||||
--disable-static \
|
||||
--with-bluetooth \
|
||||
--enable-more-warnings=yes \
|
||||
--with-gtkver=3
|
||||
make %{?_smp_mflags}
|
||||
popd
|
||||
|
||||
%install
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
|
||||
# install NM
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
|
||||
%{__cp} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
|
||||
|
||||
# install the applet
|
||||
pushd network-manager-applet-%{realversion}
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
popd
|
||||
%{__cp} %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
|
||||
|
||||
# create a VPN directory
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/VPN
|
||||
@ -283,13 +212,10 @@ popd
|
||||
%{__mkdir_p} $RPM_BUILD_ROOT%{_localstatedir}/lib/NetworkManager
|
||||
|
||||
%find_lang %{name}
|
||||
%find_lang nm-applet
|
||||
cat nm-applet.lang >> %{name}.lang
|
||||
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/pppd/%{ppp_version}/*.la
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/NetworkManager/*.la
|
||||
%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/gnome-bluetooth/plugins/*.la
|
||||
|
||||
install -m 0755 test/.libs/nm-online %{buildroot}/%{_bindir}
|
||||
|
||||
@ -297,12 +223,6 @@ install -m 0755 test/.libs/nm-online %{buildroot}/%{_bindir}
|
||||
%{__cp} ORIG-docs/libnm-glib/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/libnm-glib/
|
||||
%{__cp} ORIG-docs/libnm-util/html/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/libnm-util/
|
||||
|
||||
# don't autostart in KDE on F13+ (#541353)
|
||||
echo 'NotShowIn=KDE;' >>$RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/nm-applet.desktop
|
||||
|
||||
# validate the autostart .desktop file
|
||||
desktop-file-validate $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/nm-applet.desktop
|
||||
|
||||
|
||||
%clean
|
||||
%{__rm} -rf $RPM_BUILD_ROOT
|
||||
@ -347,37 +267,6 @@ exit 0
|
||||
%post glib -p /sbin/ldconfig
|
||||
%postun glib -p /sbin/ldconfig
|
||||
|
||||
%pre gnome
|
||||
if [ "$1" -gt 1 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
fi
|
||||
|
||||
%preun gnome
|
||||
if [ "$1" -eq 0 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
fi
|
||||
|
||||
%post gnome
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
|
||||
%postun gnome
|
||||
if [ $1 -eq 0 ] ; then
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
fi
|
||||
|
||||
%posttrans gnome
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root,0755)
|
||||
@ -435,24 +324,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%dir %{_datadir}/gtk-doc/html/NetworkManager
|
||||
%{_datadir}/gtk-doc/html/NetworkManager/*
|
||||
|
||||
%files gnome
|
||||
%defattr(-,root,root,0755)
|
||||
%{_bindir}/nm-applet
|
||||
%{_bindir}/nm-connection-editor
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/nm-applet/
|
||||
%{_datadir}/icons/hicolor/16x16/apps/*.png
|
||||
%{_datadir}/icons/hicolor/22x22/apps/*.png
|
||||
%{_datadir}/icons/hicolor/32x32/apps/*.png
|
||||
%{_datadir}/icons/hicolor/48x48/apps/*.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/*.svg
|
||||
%{_sysconfdir}/xdg/autostart/nm-applet.desktop
|
||||
%dir %{_datadir}/gnome-vpn-properties
|
||||
%{_sysconfdir}/gconf/schemas/nm-applet.schemas
|
||||
%ifnarch s390 s390x
|
||||
%{_libdir}/gnome-bluetooth/plugins/*
|
||||
%endif
|
||||
|
||||
%files glib
|
||||
%defattr(-,root,root,0755)
|
||||
%{_libdir}/libnm-glib.so.*
|
||||
@ -482,20 +353,21 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%dir %{_datadir}/gtk-doc/html/libnm-util
|
||||
%{_datadir}/gtk-doc/html/libnm-util/*
|
||||
|
||||
%files gtk
|
||||
%defattr(-,root,root,0755)
|
||||
%{_libdir}/libnm-gtk.so.*
|
||||
%dir %{_datadir}/libnm-gtk
|
||||
%{_datadir}/libnm-gtk/*.ui
|
||||
|
||||
%files gtk-devel
|
||||
%defattr(-,root,root,0755)
|
||||
%dir %{_includedir}/libnm-gtk
|
||||
%{_includedir}/libnm-gtk/*.h
|
||||
%{_libdir}/pkgconfig/libnm-gtk.pc
|
||||
%{_libdir}/libnm-gtk.so
|
||||
|
||||
%changelog
|
||||
* Mon Mar 19 2012 Dan Williams <dcbw@redhat.com> - 0.9.3.997-1
|
||||
- applet: move to network-manager-applet RPM
|
||||
- editor: move to nm-connection-editor RPM
|
||||
- libnm-gtk: move to libnm-gtk RPM
|
||||
|
||||
* Mon Mar 19 2012 Dan Williams <dcbw@redhat.com> - 0.9.3.997-0.7
|
||||
- Update to 0.9.3.997 (0.9.4-rc1)
|
||||
- core: fix possible WiFi hang when connecting to Ad-Hoc networks
|
||||
- core: enhanced IPv6 compatibility
|
||||
- core: proxy DNSSEC data when using the 'dnsmasq' caching nameserver plugin
|
||||
- core: allow VPNs to specify multiple domain names given by the server
|
||||
- core: fix an issue creating new InfiniBand connections
|
||||
- core/applet/editor: disable WiFi Ad-Hoc WPA connections until kernel bugs are fixed
|
||||
|
||||
* Wed Mar 14 2012 Dan Williams <dcbw@redhat.com> - 0.9.3.995-0.6
|
||||
- core: fix issue with carrier changes not being recognized (rh #800690)
|
||||
- editor: warn user if CA certificate is left blank
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac.foo NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac
|
||||
--- NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac.foo 2011-11-10 15:10:45.268107655 -0600
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac 2011-11-10 15:10:51.902024720 -0600
|
||||
@@ -179,8 +179,6 @@ dnl
|
||||
dnl Compiler flags
|
||||
dnl
|
||||
NM_COMPILER_WARNINGS
|
||||
-# Use --enable-maintainer-mode to disabled deprecated symbols
|
||||
-GNOME_MAINTAINER_MODE_DEFINES
|
||||
|
||||
|
||||
AC_CONFIG_FILES([
|
@ -1,232 +0,0 @@
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/configure.ac
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/configure.ac
|
||||
@@ -98,10 +98,6 @@ PKG_CHECK_MODULES(GOBJECT, gobject-2.0)
|
||||
PKG_CHECK_MODULES(NMA,
|
||||
[dbus-glib-1 >= 0.74
|
||||
glib-2.0 >= 2.16
|
||||
- NetworkManager >= 0.9.3
|
||||
- libnm-glib >= 0.9.3
|
||||
- libnm-util >= 0.9.3
|
||||
- libnm-glib-vpn >= 0.9.3
|
||||
gmodule-export-2.0])
|
||||
|
||||
PKG_CHECK_MODULES(GCONF, [gconf-2.0])
|
||||
@@ -167,8 +163,7 @@ case "${with_bluetooth}" in
|
||||
AC_MSG_CHECKING(for gnome-bluetooth)
|
||||
PKG_CHECK_MODULES(GNOME_BLUETOOTH,
|
||||
gnome-bluetooth-1.0 >= 2.27.6
|
||||
- libnm-util >= 0.9.3
|
||||
- libnm-glib >= 0.9.3,
|
||||
+ dbus-glib-1,
|
||||
have_gbt=yes, have_gbt=no)
|
||||
;;
|
||||
esac
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/connection-editor/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/connection-editor/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/connection-editor/Makefile.am
|
||||
@@ -1,5 +1,9 @@
|
||||
bin_PROGRAMS = nm-connection-editor
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
nm_connection_editor_CPPFLAGS = \
|
||||
$(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
@@ -66,7 +70,10 @@ nm_connection_editor_LDADD = \
|
||||
${top_builddir}/src/libnm-gtk/libnm-gtk.la \
|
||||
$(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
- -lm
|
||||
+ -lm \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib-vpn.la
|
||||
|
||||
uidir = $(datadir)/nm-applet
|
||||
ui_DATA = \
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gconf-helpers/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/gconf-helpers/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gconf-helpers/Makefile.am
|
||||
@@ -1,5 +1,9 @@
|
||||
SUBDIRS=. tests
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
noinst_LTLIBRARIES = \
|
||||
libgconf-helpers.la \
|
||||
libgconf-helpers-test.la
|
||||
@@ -23,7 +27,9 @@ libgconf_helpers_la_LIBADD = \
|
||||
$(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
$(GCONF_LIBS) \
|
||||
- $(GNOME_KEYRING_LIBS)
|
||||
+ $(GNOME_KEYRING_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
|
||||
#########################
|
||||
# Test library
|
||||
@@ -40,5 +46,7 @@ libgconf_helpers_test_la_CPPFLAGS = \
|
||||
|
||||
# no keyring or gconf libs since we'll override them
|
||||
libgconf_helpers_test_la_LIBADD = \
|
||||
- $(NMA_LIBS)
|
||||
+ $(NMA_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gconf-helpers/tests/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/gconf-helpers/tests/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gconf-helpers/tests/Makefile.am
|
||||
@@ -1,4 +1,7 @@
|
||||
-INCLUDES = -I$(top_srcdir)/src/utils
|
||||
+INCLUDES = -I$(top_srcdir)/src/utils \
|
||||
+ -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
|
||||
noinst_PROGRAMS = test-upgrade
|
||||
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gnome-bluetooth/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/gnome-bluetooth/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/gnome-bluetooth/Makefile.am
|
||||
@@ -6,6 +6,9 @@ INCLUDES = \
|
||||
-I${top_builddir}/src/marshallers \
|
||||
-I${top_srcdir}/src/utils \
|
||||
-I${top_srcdir}/src/libnm-gtk \
|
||||
+ -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib \
|
||||
$(GNOME_BLUETOOTH_CFLAGS) \
|
||||
$(DISABLE_DEPRECATED) \
|
||||
$(WARN_CFLAGS)
|
||||
@@ -25,7 +28,9 @@ libnma_la_LIBADD = \
|
||||
$(top_builddir)/src/marshallers/libmarshallers.la \
|
||||
$(top_builddir)/src/utils/libutils.la \
|
||||
$(top_builddir)/src/libnm-gtk/libnm-gtk.la \
|
||||
- $(GNOME_BLUETOOTH_LIBS)
|
||||
+ $(GNOME_BLUETOOTH_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
endif
|
||||
|
||||
EXTRA_DIST = $(BT_WIDGET_SOURCES)
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/Makefile.am
|
||||
@@ -2,6 +2,10 @@ SUBDIRS = marshallers utils gconf-helper
|
||||
|
||||
bin_PROGRAMS = nm-applet
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
nm_applet_CPPFLAGS = \
|
||||
$(GTK_CFLAGS) \
|
||||
$(NMA_CFLAGS) \
|
||||
@@ -72,7 +76,9 @@ nm_applet_LDADD = \
|
||||
${top_builddir}/src/utils/libutils.la \
|
||||
${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
|
||||
${top_builddir}/src/wireless-security/libwireless-security.la \
|
||||
- ${top_builddir}/src/libnm-gtk/libnm-gtk.la
|
||||
+ ${top_builddir}/src/libnm-gtk/libnm-gtk.la \
|
||||
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
|
||||
uidir = $(datadir)/nm-applet
|
||||
ui_DATA = gsm-unlock.ui info.ui wired-8021x.ui keyring.png
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/utils/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/utils/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/utils/Makefile.am
|
||||
@@ -1,5 +1,9 @@
|
||||
SUBDIRS=. tests
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
noinst_LTLIBRARIES = libutils.la
|
||||
|
||||
libutils_la_SOURCES = \
|
||||
@@ -17,3 +21,6 @@ libutils_la_CPPFLAGS = \
|
||||
-I${top_srcdir}/src
|
||||
|
||||
libutils_la_LIBADD = $(GTK_LIBS) $(NMA_LIBS) $(GNOME_KEYRING_LIBS)
|
||||
+libutils_la_LIBADD = $(GTK_LIBS) $(NMA_LIBS) $(GNOME_KEYRING_LIBS) \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/utils/tests/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/utils/tests/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/utils/tests/Makefile.am
|
||||
@@ -1,4 +1,7 @@
|
||||
-INCLUDES = -I$(top_srcdir)/src/utils
|
||||
+INCLUDES = -I$(top_srcdir)/src/utils \
|
||||
+ -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
|
||||
noinst_PROGRAMS = test-utils
|
||||
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/wireless-security/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/wireless-security/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/wireless-security/Makefile.am
|
||||
@@ -1,5 +1,9 @@
|
||||
noinst_LTLIBRARIES = libwireless-security.la
|
||||
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
libwireless_security_la_SOURCES = \
|
||||
wireless-security.h \
|
||||
wireless-security.c \
|
||||
@@ -40,7 +44,9 @@ libwireless_security_la_LIBADD = \
|
||||
$(GTK_LIBS) \
|
||||
$(NMA_LIBS) \
|
||||
$(GCONF_LIBS) \
|
||||
- ${top_builddir}/src/utils/libutils.la
|
||||
+ ${top_builddir}/src/utils/libutils.la \
|
||||
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la
|
||||
|
||||
uidir = $(datadir)/nm-applet
|
||||
ui_DATA = \
|
||||
Index: NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/Makefile.am
|
||||
===================================================================
|
||||
--- NetworkManager-0.9.3.995.orig/network-manager-applet-0.9.3.995/src/libnm-gtk/Makefile.am
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/Makefile.am
|
||||
@@ -1,3 +1,7 @@
|
||||
+INCLUDES = -I${top_srcdir}/../include \
|
||||
+ -I${top_srcdir}/../libnm-util \
|
||||
+ -I${top_srcdir}/../libnm-glib
|
||||
+
|
||||
uidir = $(datadir)/libnm-gtk
|
||||
ui_DATA = wifi.ui
|
||||
|
||||
@@ -36,7 +40,10 @@ libnm_gtk_la_LIBADD = \
|
||||
$(NMA_LIBS) \
|
||||
$(GNOME_KEYRING_LIBS) \
|
||||
$(top_builddir)/src/marshallers/libmarshallers.la \
|
||||
- $(top_builddir)/src/wireless-security/libwireless-security.la
|
||||
+ $(top_builddir)/src/wireless-security/libwireless-security.la \
|
||||
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib.la \
|
||||
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm-glib-vpn.la
|
||||
|
||||
libnm_gtk_la_LDFLAGS = -Wl,-no-undefined \
|
||||
-export-symbols-regex '^nma_.*'
|
@ -1,30 +0,0 @@
|
||||
diff -up NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/nm-applet.schemas.in.foo NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/nm-applet.schemas.in
|
||||
--- NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/nm-applet.schemas.in.foo 2009-10-21 17:23:29.480267635 -0700
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/nm-applet.schemas.in 2009-10-21 17:39:42.734142996 -0700
|
||||
@@ -6,7 +6,7 @@
|
||||
<applyto>/apps/nm-applet/disable-connected-notifications</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Disable connected notifications</short>
|
||||
<long>
|
||||
@@ -20,7 +20,7 @@
|
||||
<applyto>/apps/nm-applet/disable-disconnected-notifications</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Disable disconnected notifications</short>
|
||||
<long>
|
||||
@@ -34,7 +34,7 @@
|
||||
<applyto>/apps/nm-applet/suppress-wireless-networks-available</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Suppress networks available notifications</short>
|
||||
<long>
|
@ -1,36 +0,0 @@
|
||||
diff --git NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/nm-wireless-dialog.c NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/nm-wireless-dialog.c
|
||||
index 2cd75e0..5ae4764 100644
|
||||
--- NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/nm-wireless-dialog.c
|
||||
+++ NetworkManager-0.9.3.995/network-manager-applet-0.9.3.995/src/libnm-gtk/nm-wireless-dialog.c
|
||||
@@ -1151,24 +1151,28 @@ internal_init (NMAWirelessDialog *self,
|
||||
|
||||
tmp = g_strdup_printf (_("Passwords or encryption keys are required to access the wireless network '%s'."),
|
||||
esc_ssid ? esc_ssid : "<unknown>");
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Wireless Network Authentication Required"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("Authentication required by wireless network"),
|
||||
tmp);
|
||||
g_free (esc_ssid);
|
||||
g_free (tmp);
|
||||
} else if (priv->adhoc_create) {
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Create New Wireless Network"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("New wireless network"),
|
||||
_("Enter a name for the wireless network you wish to create."));
|
||||
} else {
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Connect to Hidden Wireless Network"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("Hidden wireless network"),
|
||||
_("Enter the name and security details of the hidden wireless network you wish to connect to."));
|
||||
}
|
||||
|
||||
+ /* The primary text should always tell the story, not the title. And since
|
||||
+ * the dialog is always on top, we can skip the taskbar.
|
||||
+ */
|
||||
+ gtk_window_set_title (GTK_WINDOW (self), "");
|
||||
+ gtk_window_set_keep_above (GTK_WINDOW (self), TRUE);
|
||||
+ gtk_window_set_skip_taskbar_hint (GTK_WINDOW (self), TRUE);
|
||||
+
|
||||
widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "caption_label"));
|
||||
gtk_label_set_markup (GTK_LABEL (widget), label);
|
||||
g_free (label);
|
Loading…
Reference in New Issue
Block a user