- New SVN snapshot of 0.7 that sucks less

This commit is contained in:
Daniel Williams 2007-09-20 14:06:41 +00:00
parent 80ed194f8f
commit b6bef11444
7 changed files with 71 additions and 106 deletions

View File

@ -2,3 +2,5 @@ network-manager-applet-0.6.5.tar.bz2
NetworkManager-0.6.5.tar.bz2
NetworkManager-0.7.0.svn2736.tar.gz
nm-applet-0.7.0.svn129.tar.gz
NetworkManager-0.7.0.svn2833.tar.gz
nm-applet-0.7.0.svn186.tar.gz

View File

@ -1,5 +1,6 @@
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-08-30 15:04:50.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-08-30 18:23:07.000000000 -0400
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-09-19 22:10:17.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-09-20 08:11:45.000000000 -0400
@@ -18,10 +18,10 @@ dnl
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
dnl uses gnome-autogen
@ -15,7 +16,7 @@
dnl
dnl Required headers
@@ -62,8 +62,6 @@ AC_CHECK_LIB(nm-util, ieee_802_11_cipher
@@ -60,8 +60,6 @@ AC_C_BIGENDIAN
PKG_CHECK_MODULES(NMA,
[dbus-glib-1 >= 0.72
glib-2.0 >= 2.10
@ -24,8 +25,54 @@
gtk+-2.0 >= 2.6
libglade-2.0
gconf-2.0
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-08-30 15:02:27.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-08-30 15:45:44.000000000 -0400
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix 2007-09-19 22:53:14.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-09-20 08:15:42.000000000 -0400
@@ -1,8 +1,15 @@
+INCLUDES = -I${top_srcdir}/../include \
+ -I${top_srcdir}/../libnm-util \
+ -I${top_srcdir}/../libnm-glib
+
noinst_LTLIBRARIES = libgconf-helpers.la
libgconf_helpers_la_SOURCES = gconf-helpers.h gconf-helpers.c
libgconf_helpers_la_CPPFLAGS = $(NMA_CFLAGS)
-libgconf_helpers_la_LIBADD = $(NMA_LIBS)
+libgconf_helpers_la_LIBADD = $(NMA_LIBS) \
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
+
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix 2007-09-20 07:40:37.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-09-20 08:16:10.000000000 -0400
@@ -2,6 +2,10 @@ NULL=
bin_PROGRAMS = nm-connection-editor
+INCLUDES = -I${top_srcdir}/../include \
+ -I${top_srcdir}/../libnm-util \
+ -I${top_srcdir}/../libnm-glib
+
nm_connection_editor_CPPFLAGS = \
$(NMA_CFLAGS) \
-DICONDIR=\""$(datadir)/icons"\" \
@@ -25,7 +29,9 @@ nm_connection_editor_SOURCES = \
nm_connection_editor_LDADD = \
$(NMA_LIBS) \
- ${top_builddir}/src/gconf-helpers/libgconf-helpers.la
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
gladedir = $(datadir)/nm-applet
glade_DATA = nm-connection-editor.glade
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-09-20 07:43:02.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-09-20 08:11:45.000000000 -0400
@@ -4,6 +4,10 @@ NULL=
bin_PROGRAMS = nm-applet
@ -37,12 +84,12 @@
nm_applet_CPPFLAGS = \
$(NMA_CFLAGS) \
-DICONDIR=\""$(datadir)/icons"\" \
@@ -89,7 +93,9 @@ if WITH_NOTIFY
nm_applet_SOURCES += applet-notifications.c applet-notifications.h
endif
@@ -62,7 +66,9 @@ endif
-nm_applet_LDADD = $(NMA_LIBS)
+nm_applet_LDADD = $(NMA_LIBS) \
nm_applet_LDADD = \
$(NMA_LIBS) \
- ${top_builddir}/src/gconf-helpers/libgconf-helpers.la
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la

View File

@ -1,35 +1,3 @@
--- NetworkManager-0.7.0/src/ppp-manager/nm-ppp-manager.c.missing-includes 2007-08-31 00:04:26.000000000 -0400
+++ NetworkManager-0.7.0/src/ppp-manager/nm-ppp-manager.c 2007-08-31 00:05:19.000000000 -0400
@@ -4,6 +4,8 @@
#include <sys/wait.h>
#include <signal.h>
#include <string.h>
+#include <sys/types.h>
+#include <unistd.h>
#include "nm-ppp-manager.h"
#include "nm-dbus-manager.h"
--- NetworkManager-0.7.0/src/nm-netlink.c.missing-includes 2007-08-30 14:45:49.000000000 -0400
+++ NetworkManager-0.7.0/src/nm-netlink.c 2007-08-30 23:58:58.000000000 -0400
@@ -19,6 +19,11 @@
* (C) Copyright 2007 Red Hat, Inc.
*/
+#include <signal.h>
+#include <pthread.h>
+#include <sys/types.h>
+#include <unistd.h>
+
#include "nm-netlink.h"
#include "nm-utils.h"
--- NetworkManager-0.7.0/src/nm-hal-manager.c.missing-includes 2007-08-30 14:45:49.000000000 -0400
+++ NetworkManager-0.7.0/src/nm-hal-manager.c 2007-08-30 23:58:58.000000000 -0400
@@ -1,3 +1,4 @@
+#include <signal.h>
#include <string.h>
#include <stdlib.h>
#include <libhal.h>
--- NetworkManager-0.7.0/test/Makefile.am.missing-includes 2007-08-30 14:45:35.000000000 -0400
+++ NetworkManager-0.7.0/test/Makefile.am 2007-08-30 23:58:58.000000000 -0400
@@ -45,5 +45,3 @@ libnm_glib_test_LDADD = $(DBUS_LIBS) $(G

View File

@ -1,21 +0,0 @@
--- NetworkManager-0.7.0/libnm-util/Makefile.am.fpic 2007-08-30 21:17:33.000000000 -0400
+++ NetworkManager-0.7.0/libnm-util/Makefile.am 2007-08-30 21:18:12.000000000 -0400
@@ -5,6 +5,7 @@ lib_LTLIBRARIES=libnm-util.la
libnm_util_la_CPPFLAGS = \
$(GLIB_CFLAGS) \
$(DBUS_CFLAGS) \
+ -fPIC \
-DDBUS_API_SUBJECT_TO_CHANGE \
-DG_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
--- NetworkManager-0.7.0/src/ppp-manager/Makefile.am.fpic 2007-08-30 14:45:45.000000000 -0400
+++ NetworkManager-0.7.0/src/ppp-manager/Makefile.am 2007-08-30 19:43:20.000000000 -0400
@@ -33,7 +33,7 @@ nm_pppd_plugin_so_SOURCES = \
nm-pppd-plugin.h \
nm-ppp-status.h
-nm_pppd_plugin_so_CPPFLAGS = $(DBUS_CFLAGS) $(GLIB_CFLAGS)
+nm_pppd_plugin_so_CPPFLAGS = $(DBUS_CFLAGS) $(GLIB_CFLAGS) -fPIC
nm_pppd_plugin_so_LDFLAGS = -shared
nm_pppd_plugin_so_LDADD = \

View File

@ -7,22 +7,20 @@ ExcludeArch: s390 s390x
%define gtk2_version 2.10.0
%define wireless_tools_version 1:28-0pre9
%define snapshot svn2736
%define snapshot svn2833
Name: NetworkManager
Summary: Network connection manager and user applications
Epoch: 1
Version: 0.7.0
Release: 0.1.%{snapshot}%{?dist}
Release: 0.2.%{snapshot}%{?dist}
Group: System Environment/Base
License: GPLv2+
URL: http://www.gnome.org/projects/NetworkManager/
Source: %{name}-%{version}.%{snapshot}.tar.gz
Source1: nm-applet-%{version}.svn129.tar.gz
Source1: nm-applet-%{version}.svn186.tar.gz
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
Patch2: NetworkManager-0.7.0-missing-includes.patch
Patch3: NetworkManager-0.7.0-ppp-manager-fpic.patch
Patch4: nm-applet-0.7.0-fixes.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
PreReq: chkconfig
@ -122,12 +120,10 @@ NetworkManager functionality from applications that use glib.
%prep
%setup -q
%patch2 -p1 -b .missing-includes
%patch3 -p1 -b .fpic
# unpack the applet
tar -xzf %{SOURCE1}
%patch1 -p1 -b .buildfix
%patch4 -p1 -b .fixes
%build
# Even though we don't require named, we still build with it
@ -232,9 +228,10 @@ fi
%files gnome
%defattr(-,root,root,0755)
%config %{_sysconfdir}/dbus-1/system.d/nm-applet.conf
%{_sysconfdir}/dbus-1/system.d/nm-applet.conf
%{_bindir}/nm-applet
%{_bindir}/nm-vpn-properties
%{_bindir}/nm-connection-editor
%{_datadir}/gnome-vpn-properties/nm-vpn-properties.glade
%{_datadir}/nm-applet/
%{_datadir}/icons/hicolor/22x22/apps/*.png
@ -252,14 +249,19 @@ fi
%files glib
%defattr(-,root,root,0755)
%{_libdir}/libnm_glib.so.*
%{_libdir}/libnm_glib_vpn.so.*
%files glib-devel
%{_includedir}/libnm-glib/*.h
%{_libdir}/pkgconfig/libnm_glib.pc
%{_libdir}/libnm_glib.so
%{_libdir}/libnm_glib_vpn.so
%changelog
* Thu Sep 20 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.2.svn2833
- New SVN snapshot of 0.7 that sucks less
* Thu Aug 30 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.1.svn2736
- Update to SVN snapshot of 0.7

View File

@ -1,33 +0,0 @@
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.h.fixes 2007-08-30 21:24:02.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/applet.h 2007-08-30 21:24:12.000000000 -0400
@@ -26,6 +26,8 @@
#include <config.h>
#endif
+#include <string.h>
+
#include <gtk/gtk.h>
#include <gconf/gconf-client.h>
#include <glade/glade.h>
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/menu-items.c.fixes 2007-08-30 21:21:14.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/menu-items.c 2007-08-30 21:21:57.000000000 -0400
@@ -228,7 +228,7 @@ nm_network_menu_item_set_ssid (NMNetwork
guint32
nm_network_menu_item_get_strength (NMNetworkMenuItem * item)
{
- g_return_if_fail (item != NULL);
+ g_return_val_if_fail (item != NULL, 0);
return item->int_strength;
}
@@ -249,8 +249,8 @@ const guchar *
nm_network_menu_item_get_hash (NMNetworkMenuItem * item,
guint32 * length)
{
- g_return_if_fail (item != NULL);
- g_return_if_fail (length != NULL);
+ g_return_val_if_fail (item != NULL, NULL);
+ g_return_val_if_fail (length != NULL, NULL);
*length = item->hash_len;
return item->hash;

View File

@ -1,2 +1,2 @@
29fcb5b6f13bf40e806a1a7a81e0f105 NetworkManager-0.7.0.svn2736.tar.gz
63540152eb1482cdcd68bc1b806672d4 nm-applet-0.7.0.svn129.tar.gz
da84c73ca684fd3abb154ea51c9a06fe NetworkManager-0.7.0.svn2833.tar.gz
98fefe2757a8be652e315b251941ed66 nm-applet-0.7.0.svn186.tar.gz