Update to NetworkManager 1.4.0 release

This commit is contained in:
Lubomir Rintel 2016-08-24 21:18:49 +02:00
parent 26675d15eb
commit ab73a3a118
4 changed files with 12 additions and 84 deletions

1
.gitignore vendored
View File

@ -327,3 +327,4 @@ network-manager-applet-0.8.1.tar.bz2
/NetworkManager-1.1.94.tar.xz
/NetworkManager-1.2.2.tar.xz
/NetworkManager-1.3.0.git20160621.072358da.tar.xz
/NetworkManager-1.4.0.tar.xz

View File

@ -1,71 +0,0 @@
From 3a4ad2c4cfc3daebf64bd5469a5b127a06611d26 Mon Sep 17 00:00:00 2001
From: Tony Espy <espy@canonical.com>
Date: Thu, 16 Jun 2016 15:07:33 -0400
Subject: [PATCH 1/2] wifi: clear WiFi requested_scan if suppl exits
It's possible for wpa_supplicant to exit with an
outstanding requested_scan pending. This can lead
to a stall condition where scanning no longer occurs.
https://mail.gnome.org/archives/networkmanager-list/2016-June/msg00117.html
(cherry picked from commit 899d7e5cb1eb3bddaf92de3644c49c9f634b675e)
---
src/devices/wifi/nm-device-wifi.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/devices/wifi/nm-device-wifi.c b/src/devices/wifi/nm-device-wifi.c
index a88d6eb..8220776 100644
--- a/src/devices/wifi/nm-device-wifi.c
+++ b/src/devices/wifi/nm-device-wifi.c
@@ -247,6 +247,11 @@ supplicant_interface_release (NMDeviceWifi *self)
priv = NM_DEVICE_WIFI_GET_PRIVATE (self);
+ if (priv->requested_scan) {
+ priv->requested_scan = FALSE;
+ nm_device_remove_pending_action (NM_DEVICE (self), "scan", TRUE);
+ }
+
nm_clear_g_source (&priv->pending_scan_id);
/* Reset the scan interval to be pretty frequent when disconnected */
--
2.7.4
From ba216887c6c213aed9d37e4125c73604ef10c9da Mon Sep 17 00:00:00 2001
From: Tony Espy <espy@canonical.com>
Date: Thu, 16 Jun 2016 15:07:32 -0400
Subject: [PATCH 2/2] wifi: clear WiFi requested_scan if suppl goes INACTIVE
It's possible for wpa_supplicant to transition to INACTIVE
state with an outstanding requested_scan pending. This can
lead to a stall condition where scanning no longer occurs.
[thaller@redhat.com: added break statement to avoid fall-through]
https://mail.gnome.org/archives/networkmanager-list/2016-June/msg00116.html
(cherry picked from commit eed8fd2e43d244caa856d9993e750ff19ba62fd7)
---
src/devices/wifi/nm-device-wifi.c | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/src/devices/wifi/nm-device-wifi.c b/src/devices/wifi/nm-device-wifi.c
index 8220776..781ecb7 100644
--- a/src/devices/wifi/nm-device-wifi.c
+++ b/src/devices/wifi/nm-device-wifi.c
@@ -1959,6 +1959,11 @@ supplicant_iface_state_cb (NMSupplicantInterface *iface,
else
_LOGI (LOGD_DEVICE | LOGD_WIFI, "supplicant interface keeps failing, giving up");
break;
+ case NM_SUPPLICANT_INTERFACE_STATE_INACTIVE:
+ priv->requested_scan = FALSE;
+ nm_clear_g_source (&priv->pending_scan_id);
+ request_wireless_scan (self, NULL);
+ break;
default:
break;
}
--
2.7.4

View File

@ -7,11 +7,10 @@
%global ppp_version %(sed -n 's/^#define\\s*VERSION\\s*"\\([^\\s]*\\)"$/\\1/p' %{_includedir}/pppd/patchlevel.h 2>/dev/null | grep . || echo bad)
%global snapshot git20160621
%global git_sha 072358da
%global snapshot %{nil}
%global git_sha %{nil}
%global rpm_version 1.4.0
%global real_version 1.3.0
%global release_version 0.5
%global release_version 1
%global epoch_version 1
%global obsoletes_nmver 1:0.9.9.95-1
@ -92,13 +91,11 @@ Group: System Environment/Base
License: GPLv2+
URL: http://www.gnome.org/projects/NetworkManager/
Source: https://download.gnome.org/sources/NetworkManager/1.4/%{name}-%{real_version}%{snap}.tar.xz
Source: https://download.gnome.org/sources/NetworkManager/1.4/%{name}-%{version}%{snap}.tar.xz
Source1: NetworkManager.conf
Source2: 00-server.conf
Source3: 20-connectivity-fedora.conf
Patch1: 0001-wifi-on-resume-rh1362165.patch
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
@ -337,9 +334,7 @@ by nm-connection-editor and nm-applet in a non-graphical environment.
%endif
%prep
%setup -q -n NetworkManager-%{real_version}
%patch1 -p1
%setup -q
%build
gtkdocize
@ -447,8 +442,8 @@ rm -f %{buildroot}%{_libdir}/NetworkManager/*.la
find %{buildroot}%{_datadir}/gtk-doc -exec touch --reference configure.ac '{}' \+
%if 0%{?__debug_package}
mkdir -p %{buildroot}%{_prefix}/src/debug/NetworkManager-%{real_version}
cp valgrind.suppressions %{buildroot}%{_prefix}/src/debug/NetworkManager-%{real_version}
mkdir -p %{buildroot}%{_prefix}/src/debug/NetworkManager-%{version}
cp valgrind.suppressions %{buildroot}%{_prefix}/src/debug/NetworkManager-%{version}
%endif
@ -642,6 +637,9 @@ fi
%endif
%changelog
* Wed Aug 24 2016 Lubomir Rintel <lkundrak@v3.sk> - 1:1.4.0-1
- Update to NetworkManager 1.4.0 release
* Thu Aug 11 2016 Thomas Haller <thaller@redhat.com> - 1:1.4.0-0.5.git20160621.072358da
- fix stale Wi-Fi after resume from suspend (rh#1362165)

View File

@ -1 +1 @@
a0cc1a7bf3e85030b7bf53c3b981d4ce NetworkManager-1.3.0.git20160621.072358da.tar.xz
337e676261ca94af08f8e9b6f9b09a5b NetworkManager-1.4.0.tar.xz