- Fix issues with the Fedora plugin not noticing changes made by

system-config-network (rh #444502)
- Allow autoconnection of GSM and CDMA connections
- Multiple IP address support for user connections
- Fixes for Mobile Broadband cards that return line speed on connect
- Implement PIN entry for GSM mobile broadband connections
- Fix crash when editing unencrypted WiFi connections in the connection
    editor
This commit is contained in:
Daniel Williams 2008-05-13 22:40:04 +00:00
parent 4a90bfc5b2
commit 818e4dcd38
4 changed files with 22 additions and 23 deletions

View File

@ -47,10 +47,11 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buil
noinst_LTLIBRARIES = libgconf-helpers.la
libgconf_helpers_la_SOURCES = \
@@ -13,5 +17,7 @@ libgconf_helpers_la_CPPFLAGS = \
@@ -13,6 +17,8 @@ libgconf_helpers_la_CPPFLAGS = \
libgconf_helpers_la_LIBADD = \
$(NMA_LIBS) \
${top_builddir}/src/marshallers/libmarshallers.la \
- ${top_builddir}/src/utils/libutils.la
+ ${top_builddir}/src/utils/libutils.la \
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
@ -123,12 +124,13 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
nm_connection_editor_CPPFLAGS = \
$(NMA_CFLAGS) \
-DICONDIR=\""$(datadir)/icons"\" \
@@ -29,7 +33,9 @@ nm_connection_editor_LDADD = \
@@ -29,8 +33,10 @@ nm_connection_editor_LDADD = \
$(top_builddir)/src/gconf-helpers/libgconf-helpers.la \
${top_builddir}/src/wireless-security/libwireless-security.la \
${top_builddir}/src/utils/libutils.la \
- $(NMA_LIBS)
+ $(NMA_LIBS) \
$(NMA_LIBS) \
- $(POLKIT_LIBS)
+ $(POLKIT_LIBS) \
+ -L${top_builddir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la

View File

@ -9,8 +9,8 @@ ExcludeArch: s390 s390x
%define libnl_version 1.0-0.15.pre8.git20071218
%define ppp_version 2.2.4
%define snapshot svn3623
%define applet_snapshot svn709
%define snapshot svn3665
%define applet_snapshot svn724
Name: NetworkManager
Summary: Network connection manager and user applications
@ -24,7 +24,6 @@ Source: %{name}-%{version}.%{snapshot}.tar.gz
Source1: nm-applet-%{version}.%{applet_snapshot}.tar.gz
Source2: nm-system-settings.conf
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
Patch2: no-strict-aliasing.patch
Patch3: optionally-wait-for-network.patch
Patch4: serial-debug.patch
Patch5: explain-dns1-dns2.patch
@ -66,6 +65,7 @@ BuildRequires: perl(XML::Parser)
BuildRequires: automake autoconf intltool libtool
BuildRequires: ppp-devel >= %{ppp_version}
BuildRequires: nss-devel >= 3.11.7
BuildRequires: PolicyKit-devel PolicyKit-gnome-devel
%description
NetworkManager attempts to keep an active network connection available at all
@ -140,7 +140,6 @@ NetworkManager functionality from applications that use glib.
# unpack the applet
tar -xzf %{SOURCE1}
%patch1 -p1 -b .buildfix
%patch2 -p1 -b .no-strict-aliasing
%patch3 -p1 -b .wait-for-network
%patch4 -p1 -b .serial-debug
%patch5 -p1 -b .explain-dns1-dns2
@ -201,6 +200,7 @@ install -m 0755 test/.libs/nm-online %{buildroot}/%{_bindir}
%post
if [ "$1" == "1" ]; then
/sbin/chkconfig --add NetworkManager
/sbin/chkconfig messagebus resetpriorities
fi
%preun
@ -258,6 +258,7 @@ fi
%{_datadir}/dbus-1/system-services/org.freedesktop.NetworkManagerSystemSettings.service
%{_datadir}/dbus-1/system-services/org.freedesktop.nm_dispatcher.service
%{_libdir}/pppd/2.4.4/nm-pppd-plugin.so
%{_datadir}/PolicyKit/policy/*.policy
%files gnome
%defattr(-,root,root,0755)
@ -293,6 +294,15 @@ fi
%changelog
* Tue May 13 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.9.3.svn3665
- Fix issues with the Fedora plugin not noticing changes made by
system-config-network (rh #444502)
- Allow autoconnection of GSM and CDMA connections
- Multiple IP address support for user connections
- Fixes for Mobile Broadband cards that return line speed on connect
- Implement PIN entry for GSM mobile broadband connections
- Fix crash when editing unencrypted WiFi connections in the connection editor
* Wed Apr 30 2008 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.9.3.svn3623
- Clean up the dispatcher now that it's service is gone (rh #444798)

View File

@ -1,13 +0,0 @@
diff -up NetworkManager-0.7.0/configure.in.foo NetworkManager-0.7.0/configure.in
--- NetworkManager-0.7.0/configure.in.foo 2008-02-07 22:12:04.000000000 -0500
+++ NetworkManager-0.7.0/configure.in 2008-02-07 22:12:57.000000000 -0500
@@ -238,7 +238,8 @@ if test "$GCC" = "yes" -a "$set_more_war
for option in -Wshadow -Wmissing-declarations -Wmissing-prototypes \
-Wdeclaration-after-statement -Wstrict-prototypes \
- -Wfloat-equal -Wno-unused-parameter -Wno-sign-compare; do
+ -Wfloat-equal -Wno-unused-parameter -Wno-sign-compare \
+ -fno-strict-aliasing; do
SAVE_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $option"
AC_MSG_CHECKING([whether gcc understands $option])

View File

@ -1,2 +1,2 @@
914847f5627a3c637d667a9e161ed546 nm-applet-0.7.0.svn709.tar.gz
308ac3e35ab19780534f70e46625437d NetworkManager-0.7.0.svn3623.tar.gz
67df69824f79c7b2cc54f3c479dc3a08 NetworkManager-0.7.0.svn3665.tar.gz
90afda885df096e7017ddd8aefa52657 nm-applet-0.7.0.svn724.tar.gz