- Add rfkill functionality

- Fix applet crash when choosing wired networks from the menu
This commit is contained in:
Daniel Williams 2007-10-16 20:47:39 +00:00
parent 687e9678e6
commit 2ca88e371f
4 changed files with 49 additions and 17 deletions

View File

@ -24,3 +24,9 @@ NetworkManager-0.7.0.svn2962.tar.gz
nm-applet-0.7.0.svn239.tar.gz
NetworkManager-0.7.0.svn2970.tar.gz
nm-applet-0.7.0.svn240.tar.gz
NetworkManager-0.7.0.svn2978.tar.gz
nm-applet-0.7.0.svn258.tar.gz
NetworkManager-0.7.0.svn2981.tar.gz
nm-applet-0.7.0.svn260.tar.gz
NetworkManager-0.7.0.svn2983.tar.gz
nm-applet-0.7.0.svn261.tar.gz

View File

@ -1,6 +1,6 @@
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-09-24 11:02:11.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-09-25 03:27:22.000000000 -0400
--- NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix 2007-10-13 20:48:35.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac 2007-10-16 13:14:57.000000000 -0400
@@ -18,10 +18,10 @@ dnl
dnl This doesn't depend on gnome support, only on gnome-common, autogen already
dnl uses gnome-autogen
@ -26,8 +26,8 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/configure.ac.buildfix NetworkManag
libglade-2.0
gconf-2.0
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix 2007-09-25 03:33:31.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-09-25 03:34:10.000000000 -0400
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.buildfix 2007-09-22 22:54:27.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am 2007-10-16 13:14:57.000000000 -0400
@@ -1,6 +1,10 @@
bin_PROGRAMS = nm-vpn-properties
@ -52,7 +52,7 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/vpn-properties/Makefile.am.bui
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buildfix 2007-09-19 22:53:14.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-09-25 03:27:22.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am 2007-10-16 13:14:57.000000000 -0400
@@ -1,8 +1,15 @@
+INCLUDES = -I${top_srcdir}/../include \
+ -I${top_srcdir}/../libnm-util \
@ -70,9 +70,31 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/gconf-helpers/Makefile.am.buil
+ -L${top_builddir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
+
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am.buildfix 2007-10-16 13:25:35.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/wireless-security/Makefile.am 2007-10-16 13:26:07.000000000 -0400
@@ -1,5 +1,9 @@
noinst_LTLIBRARIES = libwireless-security.la
+INCLUDES = -I${top_srcdir}/../include \
+ -I${top_srcdir}/../libnm-util \
+ -I${top_srcdir}/../libnm-glib
+
libwireless_security_la_SOURCES = \
wireless-security.h \
wireless-security.c \
@@ -28,5 +32,7 @@ libwireless_security_la_CPPFLAGS = \
libwireless_security_la_LIBADD = \
$(NMA_LIBS) \
- ${top_builddir}/src/utils/libutils.la
+ ${top_builddir}/src/utils/libutils.la \
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.buildfix 2007-09-20 07:40:37.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-09-25 03:27:22.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am 2007-10-16 13:14:57.000000000 -0400
@@ -2,6 +2,10 @@ NULL=
bin_PROGRAMS = nm-connection-editor
@ -96,8 +118,8 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/connection-editor/Makefile.am.
gladedir = $(datadir)/nm-applet
glade_DATA = nm-connection-editor.glade
diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-09-20 07:43:02.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-09-25 03:27:22.000000000 -0400
--- NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix 2007-10-13 22:01:15.000000000 -0400
+++ NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am 2007-10-16 13:14:57.000000000 -0400
@@ -4,6 +4,10 @@ NULL=
bin_PROGRAMS = nm-applet
@ -109,12 +131,12 @@ diff -up NetworkManager-0.7.0/nm-applet-0.7.0/src/Makefile.am.buildfix NetworkMa
nm_applet_CPPFLAGS = \
$(NMA_CFLAGS) \
-DICONDIR=\""$(datadir)/icons"\" \
@@ -62,7 +66,9 @@ endif
nm_applet_LDADD = \
@@ -60,7 +64,9 @@ nm_applet_LDADD = \
$(NMA_LIBS) \
- ${top_builddir}/src/gconf-helpers/libgconf-helpers.la
+ ${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
${top_builddir}/src/utils/libutils.la \
${top_builddir}/src/gconf-helpers/libgconf-helpers.la \
- ${top_builddir}/src/wireless-security/libwireless-security.la
+ ${top_builddir}/src/wireless-security/libwireless-security.la \
+ -L${top_srcdir}/../libnm-util $(top_builddir)/../libnm-util/libnm-util.la \
+ -L${top_srcdir}/../libnm-glib $(top_builddir)/../libnm-glib/libnm_glib.la

View File

@ -7,7 +7,7 @@ ExcludeArch: s390 s390x
%define gtk2_version 2.10.0
%define wireless_tools_version 1:28-0pre9
%define snapshot svn2970
%define snapshot svn2983
Name: NetworkManager
Summary: Network connection manager and user applications
@ -18,7 +18,7 @@ Group: System Environment/Base
License: GPLv2+
URL: http://www.gnome.org/projects/NetworkManager/
Source: %{name}-%{version}.%{snapshot}.tar.gz
Source1: nm-applet-%{version}.svn240.tar.gz
Source1: nm-applet-%{version}.svn261.tar.gz
Patch1: NetworkManager-0.6.5-fixup-internal-applet-build.patch
Patch2: nm-applet-0.7.0-disable-stuff.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -260,6 +260,10 @@ fi
%changelog
* Tue Oct 16 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.3.svn2983
- Add rfkill functionality
- Fix applet crash when choosing wired networks from the menu
* Wed Oct 10 2007 Dan Williams <dcbw@redhat.com> - 1:0.7.0-0.3.svn2970
- Fix segfault with deferred connections
- Fix default username with vpnc VPN plugin

View File

@ -1,2 +1,2 @@
b37293ca2efb7bd65583656b7769fb1b NetworkManager-0.7.0.svn2970.tar.gz
efbcdc7a9300406033f56cc40ec5a372 nm-applet-0.7.0.svn240.tar.gz
7d3d314520cfa6499819c7243a14ac14 NetworkManager-0.7.0.svn2983.tar.gz
31bd3952fa8786c47ea3fac67a00255f nm-applet-0.7.0.svn261.tar.gz