add patches

This commit is contained in:
Dan Williams 2011-07-11 19:46:42 -05:00
parent c9b9b874cd
commit d9358d24cd
2 changed files with 24 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -up ModemManager-0.4/src/mm-log.c.format ModemManager-0.4/src/mm-log.c
--- ModemManager-0.4/src/mm-log.c.format 2011-01-24 14:31:25.000000000 -0600
+++ ModemManager-0.4/src/mm-log.c 2011-02-25 08:03:00.315754971 -0600
@@ -88,7 +88,7 @@ _mm_log (const char *loc,
usecs += 1000000;
}
- snprintf (&tsbuf[0], sizeof (tsbuf), " [%06ld.%06ld]", secs, usecs);
+ snprintf (&tsbuf[0], sizeof (tsbuf), " [%06ld.%06ld]", secs, (long) usecs);
}
if ((log_level & LOGL_DEBUG) && (level == LOGL_DEBUG))

View File

@ -0,0 +1,12 @@
diff -up ModemManager-0.4.998/src/tests/Makefile.am.foo ModemManager-0.4.998/src/tests/Makefile.am
--- ModemManager-0.4.998/src/tests/Makefile.am.foo 2011-07-06 17:59:53.711343366 -0500
+++ ModemManager-0.4.998/src/tests/Makefile.am 2011-07-06 18:00:08.971152593 -0500
@@ -45,7 +45,6 @@ if WITH_TESTS
check-local: test-modem-helpers
$(abs_builddir)/test-modem-helpers
$(abs_builddir)/test-charsets
- $(abs_builddir)/test-qcdm-serial-port
endif