Fix boost linking.

This commit is contained in:
Richard M. Shaw 2012-08-09 16:54:57 -05:00
parent 385d9fa20f
commit 94da07a8da
2 changed files with 15 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -Naur imageworks-Field3D-94d1bf3.orig/CMakeLists.txt imageworks-Field3D-94d1bf3/CMakeLists.txt
--- imageworks-Field3D-94d1bf3.orig/CMakeLists.txt 2012-02-04 11:37:22.000000000 -0600
+++ imageworks-Field3D-94d1bf3/CMakeLists.txt 2012-08-09 16:53:06.676930806 -0500
@@ -39,7 +39,7 @@
FIND_PACKAGE (Doxygen)
FIND_PACKAGE (HDF5)
-FIND_PACKAGE (Boost COMPONENTS thread program_options)
+FIND_PACKAGE (Boost COMPONENTS thread program_options system)
FIND_PACKAGE (ILMBase)
OPTION (INSTALL_DOCS "Automatically install documentation." ON)

View File

@ -13,6 +13,8 @@ URL: https://sites.google.com/site/field3d/
# https://nodeload.github.com/imageworks/Field3D/tarball/v1.3.2
Source0: imageworks-%{name}-v%{version}-0-%{githash1}.tar.gz
Patch0: Field3D-1.3.2-libboost.patch
BuildRequires: cmake doxygen
BuildRequires: hdf5-devel
BuildRequires: boost-devel
@ -36,6 +38,7 @@ Development headers and documentation for %{name}.
%prep
%setup -q -n imageworks-%{name}-%{githash2}
%patch0 -p1 -b .boost
%build