Update to 2.0.0-0.5.20181225git2f3a442

Rework of Carla-bswap.patch
This commit is contained in:
Martin Gansser 2018-12-25 13:39:50 +01:00
parent be46962661
commit 6a46812195
5 changed files with 61 additions and 16 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/Carla-51f2073.tar.gz
/Carla-2f3a442.tar.gz

View File

@ -1,11 +1,55 @@
--- a/source/modules/water/memory/ByteOrder.h 2018-12-21 11:41:10.199136525 +0000
+++ b/source/modules/water/memory/ByteOrder.h 2018-12-21 11:42:29.498743747 +0000
@@ -153,7 +153,7 @@
--- a/source/modules/water/memory/ByteOrder.h.orig 2018-12-25 09:55:04.000000000 +0100
+++ b/source/modules/water/memory/ByteOrder.h 2018-12-25 13:00:27.500279074 +0100
@@ -28,7 +28,11 @@
#include "../water.h"
-#ifdef CARLA_OS_MAC
+#if defined(CARLA_OS_BSD)
+# include <sys/endian.h>
+#elif defined(CARLA_OS_LINUX)
+# include <byteswap.h>
+#elif defined(CARLA_OS_MAC)
# include <libkern/OSByteOrder.h>
#endif
@@ -146,14 +150,24 @@
//==============================================================================
inline uint16 ByteOrder::swap (uint16 n) noexcept
{
#ifdef CARLA_OS_MAC
+ #if defined(CARLA_OS_BSD)
+ return bswap16 (n);
+ #elif defined(CARLA_OS_LINUX)
+ return bswap_16 (n);
+ #else
return static_cast<uint16> ((n << 8) | (n >> 8));
+ #endif
}
inline uint32 ByteOrder::swap (uint32 n) noexcept
{
- #ifdef CARLA_OS_MAC
+ #if defined(CARLA_OS_BSD)
+ return bswap32 (n);
+ #elif defined(CARLA_OS_LINUX)
+ return bswap_32 (n);
+ #elif defined(CARLA_OS_MAC)
return OSSwapInt32 (n);
- #elif defined(CARLA_OS_WIN) || ! (defined (__arm__) || defined (__arm64__) || defined (__aarch64__))
+ #elif defined(CARLA_OS_WIN) || defined(__i386__) || defined(__x86_64__)
+ #elif defined(__i386__) || defined(__x86_64__)
asm("bswap %%eax" : "=a"(n) : "a"(n));
return n;
#else
@@ -163,7 +177,11 @@
inline uint64 ByteOrder::swap (uint64 value) noexcept
{
- #ifdef CARLA_OS_MAC
+ #if defined(CARLA_OS_BSD)
+ return bswap64 (value);
+ #elif defined(CARLA_OS_LINUX)
+ return bswap_64 (value);
+ #elif defined(CARLA_OS_MAC)
return OSSwapInt64 (value);
#else
return (((uint64) swap ((uint32) value)) << 32) | swap ((uint32) (value >> 32));

View File

@ -1,11 +1,11 @@
%global commit0 51f20736b4e0b5d6416f2b7d4051f155f5858fbf
%global commit0 2f3a4424591b49689403372d35d55148bef5a51b
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
%global pname carla
%global commitdate 20181212
%global commitdate 20181225
Name: Carla
Version: 2.0.0
Release: 0.4.%{commitdate}git%{shortcommit0}%{?dist}
Release: 0.5.%{commitdate}git%{shortcommit0}%{?dist}
Summary: Audio plugin host
# The entire source code is GPLv2+ except
@ -144,15 +144,11 @@ sed -i "s|#!/usr/bin/env python|#!%{__python3}|" source/frontend/widgets/paramsp
# fix libdir path
sed -i "s|/lib/carla|/%{_lib}/carla|" data/{carla,carla-control,carla-database,carla-jack-multi,carla-jack-single,carla-patchbay,carla-rack,carla-settings}
# remove upstream optimisation options
sed -i "s|-O3 -mtune=generic -msse -msse2 -mfpmath=sse||" data/linux/build-deps.sh
sed -i "s|-O3 -ffast-math -mtune=generic -msse -msse2 -mfpmath=sse||" source/{tests/Makefile,Makefile.mk}
%build
%{set_build_flags}
# list build configuration, no need for optflags or -j
make features
%make_build SKIP_STRIPPING=true V=1
%make_build SKIP_STRIPPING=true NOOPT=true V=1
%install
%make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
@ -206,6 +202,10 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_libdir}/pkgconfig/%{pname}-native-plugin.pc
%changelog
* Tue Dec 25 2018 Martin Gansser <martinkg@fedoraproject.org> - 2.0.0-0.5.20181225git2f3a442
- Update to 2.0.0-0.5.20181225git2f3a442
- Rework of Carla-bswap.patch
* Fri Dec 21 2018 Martin Gansser <martinkg@fedoraproject.org> - 2.0.0-0.4.20181212git51f2073
- Add lv2-carla subpkg
- Take ownership of lv2/

View File

@ -1,5 +1,5 @@
--- Carla-51f20736b4e0b5d6416f2b7d4051f155f5858fbf/source/frontend/carla_shared.py.orig 2018-12-19 12:57:21.251802286 +0100
+++ Carla-51f20736b4e0b5d6416f2b7d4051f155f5858fbf/source/frontend/carla_shared.py 2018-12-19 12:59:24.154528863 +0100
--- a/source/frontend/carla_shared.py.orig 2018-12-19 12:57:21.251802286 +0100
+++ b/source/frontend/carla_shared.py 2018-12-19 12:59:24.154528863 +0100
@@ -402,19 +402,19 @@
splitter = ":"

View File

@ -1 +1 @@
SHA512 (Carla-51f2073.tar.gz) = d68952beb2b29b26c8b28483281d2c2d5a61ce55bc353a28b4f81f85d572327171a28ef1d0ecd97cffea41c928dc556388a0feeec116ff1273725a689b68a4e0
SHA512 (Carla-2f3a442.tar.gz) = 8cbfd23294e61889047134f6ed811599c46048a51367a7e8dea34a72049b9032ed860cb63252f811d0cec77e632a196d40d5b49dbcf4226b01506068bae552ae