restore abs-unsigned patch
it is not yet in upstream :/ Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
3eebddefad
commit
c2ac5d40d2
12
0ad-abs-unsigned.diff
Normal file
12
0ad-abs-unsigned.diff
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr 0ad-0.0.22-alpha.orig/source/gui/CDropDown.cpp 0ad-0.0.22-alpha/source/gui/CDropDown.cpp
|
||||
--- 0ad-0.0.22-alpha.orig/source/gui/CDropDown.cpp 2017-06-30 01:39:12.000000000 +0200
|
||||
+++ 0ad-0.0.22-alpha/source/gui/CDropDown.cpp 2017-07-27 10:03:04.647238245 +0200
|
||||
@@ -352,7 +352,7 @@
|
||||
int diff = 0;
|
||||
for (size_t j = 0; j < m_InputBuffer.length(); ++j)
|
||||
{
|
||||
- diff = std::abs(pList->m_Items[i].GetRawString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
+ diff = std::abs((int)pList->m_Items[i].GetRawString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
if (diff == 0)
|
||||
indexOfDifference = j+1;
|
||||
else
|
4
0ad.spec
4
0ad.spec
@ -110,6 +110,9 @@ Patch3: %{name}-valgrind.patch
|
||||
# And other fixes
|
||||
Patch4: %{name}-mozjs-incompatible.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1423200
|
||||
Patch5: %{name}-abs-unsigned.diff
|
||||
|
||||
%description
|
||||
0 A.D. (pronounced "zero ey-dee") is a free, open-source, cross-platform
|
||||
real-time strategy (RTS) game of ancient warfare. In short, it is a
|
||||
@ -132,6 +135,7 @@ hobbyist game developers, since 2001.
|
||||
%endif
|
||||
%patch3 -p0
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%if %{with system_nvtt}
|
||||
rm -fr libraries/source/nvtt
|
||||
|
Loading…
Reference in New Issue
Block a user