Correct build with boost 1.54.0 (#991906)
This commit is contained in:
parent
90480a022d
commit
b71416aff7
21
0ad-boost-0.54.0.patch
Normal file
21
0ad-boost-0.54.0.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up 0ad-0.0.13-alpha/build/premake/extern_libs4.lua.orig 0ad-0.0.13-alpha/build/premake/extern_libs4.lua
|
||||
--- 0ad-0.0.13-alpha/build/premake/extern_libs4.lua.orig 2013-08-07 13:37:33.983209591 -0300
|
||||
+++ 0ad-0.0.13-alpha/build/premake/extern_libs4.lua 2013-08-07 13:38:33.638211876 -0300
|
||||
@@ -242,7 +242,7 @@ extern_lib_defs = {
|
||||
-- The following are not strictly link dependencies on all systems, but
|
||||
-- are included for compatibility with different versions of Boost
|
||||
android_names = { "boost_filesystem-gcc-mt", "boost_system-gcc-mt" },
|
||||
- unix_names = { "boost_filesystem-mt", "boost_system-mt" },
|
||||
+ unix_names = { "boost_filesystem", "boost_system" },
|
||||
bsd_names = { "boost_filesystem", "boost_system" },
|
||||
})
|
||||
end,
|
||||
@@ -251,7 +251,7 @@ extern_lib_defs = {
|
||||
link_settings = function()
|
||||
add_default_links({
|
||||
android_names = { "boost_signals-gcc-mt" },
|
||||
- unix_names = { "boost_signals-mt" },
|
||||
+ unix_names = { "boost_signals" },
|
||||
bsd_names = { "boost_signals" },
|
||||
})
|
||||
end,
|
9
0ad.spec
9
0ad.spec
@ -114,6 +114,9 @@ Patch1: %{name}-saveas.patch
|
||||
# It also prevents assumption there that it is building in x86
|
||||
Patch2: %{name}-debug.patch
|
||||
|
||||
# Correct 0ad FTBFS (#991906)
|
||||
Patch3: %{name}-boost-0.54.0.patch
|
||||
|
||||
%description
|
||||
0 A.D. (pronounced "zero ey-dee") is a free, open-source, cross-platform
|
||||
real-time strategy (RTS) game of ancient warfare. In short, it is a
|
||||
@ -135,6 +138,9 @@ hobbyist game developers, since 2001.
|
||||
# disable debug build, and "int 0x3" to trap to debugger (x86 only)
|
||||
%patch2 -p1
|
||||
%endif
|
||||
%if 0%{?fedora} > 19
|
||||
%patch3 -p1
|
||||
%endif
|
||||
|
||||
%if %{with_system_nvtt}
|
||||
rm -fr libraries/nvtt
|
||||
@ -230,6 +236,9 @@ export STRIP=/bin/true
|
||||
%{_mandir}/man6/*.6*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 7 2013 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.13-7
|
||||
- Correct build with boost 1.54.0 (#991906).
|
||||
|
||||
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.13-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user