Update to latest upstream release

This commit is contained in:
pcpa 2013-04-03 12:00:33 -03:00
parent 5d92899623
commit 5d924be2a9
8 changed files with 2095 additions and 2084 deletions

4
.gitignore vendored
View File

@ -1,3 +1 @@
/0ad-0.0.11-alpha-unix-build.tar.xz /0ad-0.0.13-alpha-unix-build.tar.xz
/0ad-0.0.12-alpha-unix-build.tar.xz
/0ad-0.0.12-alpha-unix-data.tar.xz

View File

@ -1,6 +1,6 @@
diff -up 0ad-0.0.11-alpha/libraries/fcollada/src/Makefile.orig 0ad-0.0.11-alpha/libraries/fcollada/src/Makefile diff -up 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile.orig 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile
--- 0ad-0.0.11-alpha/libraries/fcollada/src/Makefile.orig 2012-11-03 09:57:05.310706564 -0200 --- 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile.orig 2013-04-03 10:18:41.527414409 -0300
+++ 0ad-0.0.11-alpha/libraries/fcollada/src/Makefile 2012-11-03 09:58:41.665710254 -0200 +++ 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile 2013-04-03 10:21:17.209420370 -0300
@@ -9,10 +9,7 @@ endif @@ -9,10 +9,7 @@ endif
CXX ?= g++ CXX ?= g++
@ -70,12 +70,12 @@ diff -up 0ad-0.0.11-alpha/libraries/fcollada/src/Makefile.orig 0ad-0.0.11-alpha/
-test: FCollada/FColladaTest/ output/FColladaTest -test: FCollada/FColladaTest/ output/FColladaTest
- ( cd FCollada/FColladaTest/ ; ../../output/FColladaTest ) - ( cd FCollada/FColladaTest/ ; ../../output/FColladaTest )
- cat FCollada/FColladaTest/FColladaTestLog.txt - cat FCollada/FColladaTest/FColladaTestLog.txt
+ bash -c 'mkdir -p output/release/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}' -
-output/libFColladaSD.a: $(OBJECTS_DEBUG) -output/libFColladaSD.a: $(OBJECTS_DEBUG)
- @echo "$@" - @echo "$@"
- @ar -cr $@ $(OBJECTS_DEBUG); ranlib $@ - @ar -cr $@ $(OBJECTS_DEBUG); ranlib $@
- + bash -c 'mkdir -p output/release/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}'
output/libFColladaSR.a: $(OBJECTS_RELEASE) output/libFColladaSR.a: $(OBJECTS_RELEASE)
@echo "$@" @echo "$@"
@ar -cr $@ $(OBJECTS_RELEASE); ranlib $@ @ar -cr $@ $(OBJECTS_RELEASE); ranlib $@

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
diff -up 0ad-0.0.12-alpha/build/premake/premake4.lua.orig 0ad-0.0.12-alpha/build/premake/premake4.lua diff -up 0ad-0.0.13-alpha/build/premake/premake4.lua.orig 0ad-0.0.13-alpha/build/premake/premake4.lua
--- 0ad-0.0.12-alpha/build/premake/premake4.lua.orig 2012-10-29 22:56:24.000000000 -0200 --- 0ad-0.0.13-alpha/build/premake/premake4.lua.orig 2013-04-03 10:11:08.168397048 -0300
+++ 0ad-0.0.12-alpha/build/premake/premake4.lua 2012-12-18 20:30:20.851551919 -0200 +++ 0ad-0.0.13-alpha/build/premake/premake4.lua 2013-04-03 10:13:06.433401577 -0300
@@ -303,26 +303,6 @@ function project_set_build_flags() @@ -313,26 +313,6 @@ function project_set_build_flags()
defines { "INSTALLED_LIBDIR=" .. _OPTIONS["libdir"] } defines { "INSTALLED_LIBDIR=" .. _OPTIONS["libdir"] }
end end

View File

@ -1,7 +1,7 @@
diff -up 0ad-0.0.11-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 0ad-0.0.11-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp diff -up 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp
--- 0ad-0.0.11-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 2012-11-03 13:31:29.921199195 -0200 --- 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 2013-04-03 10:15:59.888408219 -0300
+++ 0ad-0.0.11-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp 2012-11-03 15:57:00.017533500 -0200 +++ 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp 2013-04-03 10:16:13.753408750 -0300
@@ -691,30 +691,20 @@ bool ScenarioEditor::OpenFile(const wxSt @@ -692,30 +692,20 @@ bool ScenarioEditor::OpenFile(const wxSt
void ScenarioEditor::OnOpen(wxCommandEvent& WXUNUSED(event)) void ScenarioEditor::OnOpen(wxCommandEvent& WXUNUSED(event))
{ {
@ -45,7 +45,7 @@ diff -up 0ad-0.0.11-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEdit
} }
void ScenarioEditor::OnImportHeightmap(wxCommandEvent& WXUNUSED(event)) void ScenarioEditor::OnImportHeightmap(wxCommandEvent& WXUNUSED(event))
@@ -778,40 +768,57 @@ void ScenarioEditor::OnSave(wxCommandEve @@ -779,40 +769,57 @@ void ScenarioEditor::OnSave(wxCommandEve
void ScenarioEditor::OnSaveAs(wxCommandEvent& WXUNUSED(event)) void ScenarioEditor::OnSaveAs(wxCommandEvent& WXUNUSED(event))
{ {

25
0ad.6
View File

@ -1,7 +1,7 @@
.TH 0AD "1" "Dec 16 2012" "0ad 0.0.12" "User Commands" .TH 0AD "1" "Apr 2 2013" "0ad 0.0.13" "User Commands"
.SH NAME .SH NAME
0ad \- manual page for 0ad 0.0.12 0ad \- manual page for 0ad 0.0.13
.SH SYNOPSIS .SH SYNOPSIS
.B 0ad .B 0ad
[\fIoptions\fR] [\fIoptions\fR]
@ -39,6 +39,9 @@ map \fINAME\fR for scenario, or rms name for random map
.TP .TP
\fB\-autostart-ai\fR=\fIPLAYER\fR:\fIAI\fR \fB\-autostart-ai\fR=\fIPLAYER\fR:\fIAI\fR
adds named \fIAI\fR to the given \fIPLAYER\fR (e.g. 2:testbot) adds named \fIAI\fR to the given \fIPLAYER\fR (e.g. 2:testbot)
.TP
\fB-autostart-aidiff\fR=\fIPLAYER\fR:\fIlevel\fR
changes the difficulty setting for \fIAI PLAYER\fR (0: easy, 3: very hard)
.PP .PP
Multiplayer: Multiplayer:
@ -72,6 +75,9 @@ random map \fISIZE\fR in tiles (default 192)
.TP .TP
\fB\-autostart-players\fR=\fINUMBER\fI \fB\-autostart-players\fR=\fINUMBER\fI
\fINUMBER\fR of players on random map \fINUMBER\fR of players on random map
.TP
\fB-autostart-civ\fR=\fIPLAYER\fR:\fICIV\fR
changes the civilisation of player \fIPLAYER\fR to \fICIV\fR (default athen)
.PP .PP
Configuration: Configuration:
@ -85,8 +91,8 @@ set the gamma correction to '\fIF\fR' (default 1.0)
\fB\-nosound\fR \fB\-nosound\fR
disable audio disable audio
.TP .TP
\fB\-onlyPublicFiles\fR \fB-noUserMod\fR
force game to use only the public (default) mod disable loading of the user mod
.TP .TP
\fB\-shadows\fR \fB\-shadows\fR
enable shadows enable shadows
@ -104,7 +110,7 @@ set screen \fIY\fR resolution to '\fIN\fR'
Advanced / diagnostic: Advanced / diagnostic:
.TP .TP
\fB\-dumpSchema\fR \fB\-dumpSchema\fR
creates a file entity.rng in the working directory, containing creates a file \fIentity.rng\fR in the working directory, containing
complete entity XML schema, used by various analysis tools complete entity XML schema, used by various analysis tools
.TP .TP
\fB\-entgraph\fR \fB\-entgraph\fR
@ -151,13 +157,8 @@ enable deflate compression in the .zip
(disabled) (disabled)
.SH "REPORTING BUGS" .SH "REPORTING BUGS"
Bugs should be reported on Trac: http://trac.wildfiregames.com/ Bugs should be reported on Trac. For information on reporting problems
.br and finding logs, see http://trac.wildfiregames.com/wiki/ReportingErrors
On Linux / OS X: If the game detects an error, it should generate crashlog.txt
in ~/.config/0ad/logs/ . If it doesn't, it should at least print some
information on stdout. Attach crashlog.txt or the other information to the
bug report. It might also help to run the game in gdb and copy the output of
the "bt full" command, if possible.
.SH COPYRIGHT .SH COPYRIGHT
0 A.D. is released as open source: you can freely use, copy, modify and 0 A.D. is released as open source: you can freely use, copy, modify and

View File

@ -24,8 +24,8 @@
%endif %endif
Name: 0ad Name: 0ad
Version: 0.0.12 Version: 0.0.13
Release: 5%{?dist} Release: 1%{?dist}
# BSD License: # BSD License:
# build/premake/* # build/premake/*
# libraries/valgrind/* (not built/used) # libraries/valgrind/* (not built/used)
@ -44,7 +44,7 @@ Release: 5%{?dist}
License: GPLv2+ and BSD and MIT and IBM License: GPLv2+ and BSD and MIT and IBM
Group: Amusements/Games Group: Amusements/Games
Summary: Cross-Platform RTS Game of Ancient Warfare Summary: Cross-Platform RTS Game of Ancient Warfare
Url: http://wildfiregames.com/0ad/ Url: http://play0ad.com
%if %{without_nvtt} %if %{without_nvtt}
# wget http://releases.wildfiregames.com/%%{name}-%%{version}-alpha-unix-build.tar.xz # wget http://releases.wildfiregames.com/%%{name}-%%{version}-alpha-unix-build.tar.xz
@ -61,7 +61,7 @@ Source0: http://releases.wildfiregames.com/%{name}-%{version}-alpha-unix-build.t
# (also to validate one did not forget to remake the tarball if # (also to validate one did not forget to remake the tarball if
# %{without_nvtt} is enabled) Create it with: # %{without_nvtt} is enabled) Create it with:
# cd BUILD/%{name}-%{version}-alpha # cd BUILD/%{name}-%{version}-alpha
# licensecheck -r . > ../../SOURCES/%{name}-licensecheck.txt # licensecheck -r . | sort > ../../SOURCES/%{name}-licensecheck.txt
Source1: %{name}-licensecheck.txt Source1: %{name}-licensecheck.txt
# adapted from binaries/system/readme.txt # adapted from binaries/system/readme.txt
@ -230,6 +230,11 @@ export STRIP=/bin/true
%{_mandir}/man6/*.6* %{_mandir}/man6/*.6*
%changelog %changelog
* Wed Apr 3 2013 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.13-1
- Update to latest upstream release
- Update the manual page for new and renamed options
- Regenerate the licensecheck text file and patches
* Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 0.0.12-5 * Sun Feb 10 2013 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 0.0.12-5
- Rebuild for Boost-1.53.0 - Rebuild for Boost-1.53.0
@ -239,13 +244,13 @@ export STRIP=/bin/true
* Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 0.0.12-3 * Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 0.0.12-3
- rebuild due to "jpeg8-ABI" feature drop - rebuild due to "jpeg8-ABI" feature drop
* Wed Dec 19 2012 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.11-2 * Wed Dec 19 2012 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.12-2
- Enable build with system nvtt as it is now approved in Fedora (#823096) - Enable build with system nvtt as it is now approved in Fedora (#823096)
- Correct release date in manual page - Correct release date in manual page
- Minor consistency correction in manual page formatting - Minor consistency correction in manual page formatting
- Regenerate the licensecheck text file to match pristine tarball - Regenerate the licensecheck text file to match pristine tarball
* Tue Dec 18 2012 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.11-1 * Tue Dec 18 2012 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.12-1
- Update to latest upstream release - Update to latest upstream release
- Remove no longer required gamin patch - Remove no longer required gamin patch
- Rediff rpath patch - Rediff rpath patch

View File

@ -1 +1 @@
0ff92fb2b22b5384067cdd88b89e5450 0ad-0.0.12-alpha-unix-build.tar.xz 3075c982c4af41a3586b6b6ef637d2c4 0ad-0.0.13-alpha-unix-build.tar.xz