Update to 0.0.22
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
This commit is contained in:
parent
85e3a5263a
commit
3eebddefad
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/0ad-0.0.19-alpha-unix-build.tar.xz
|
||||
/0ad-0.0.20-alpha-unix-build.tar.xz
|
||||
/0ad-0.0.21-alpha-unix-build.tar.xz
|
||||
/0ad-0.0.22-alpha-unix-build.tar.xz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- 0ad-0.0.21-alpha/source/gui/CDropDown.cpp.orig 2017-07-17 18:52:09.775883922 +0100
|
||||
+++ 0ad-0.0.21-alpha/source/gui/CDropDown.cpp 2017-07-17 18:52:13.235881914 +0100
|
||||
@@ -345,7 +345,7 @@
|
||||
int diff = 0;
|
||||
for (size_t j = 0; j < m_InputBuffer.length(); ++j)
|
||||
{
|
||||
- diff = abs(pList->m_Items[i].GetOriginalString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
+ diff = abs((int)pList->m_Items[i].GetOriginalString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
if (diff == 0)
|
||||
indexOfDifference = j+1;
|
||||
else
|
4503
0ad-licensecheck.txt
4503
0ad-licensecheck.txt
File diff suppressed because it is too large
Load Diff
13
0ad.spec
13
0ad.spec
@ -18,8 +18,8 @@
|
||||
%bcond_without nvtt
|
||||
|
||||
Name: 0ad
|
||||
Version: 0.0.21
|
||||
Release: 6%{?dist}
|
||||
Version: 0.0.22
|
||||
Release: 1%{?dist}
|
||||
# BSD License:
|
||||
# build/premake/*
|
||||
# libraries/source/miniupnpc/* (not built/used)
|
||||
@ -110,9 +110,6 @@ Patch3: %{name}-valgrind.patch
|
||||
# And other fixes
|
||||
Patch4: %{name}-mozjs-incompatible.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1423200
|
||||
Patch5: %{name}-abs-unsigned.patch
|
||||
|
||||
%description
|
||||
0 A.D. (pronounced "zero ey-dee") is a free, open-source, cross-platform
|
||||
real-time strategy (RTS) game of ancient warfare. In short, it is a
|
||||
@ -135,7 +132,6 @@ hobbyist game developers, since 2001.
|
||||
%endif
|
||||
%patch3 -p0
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%if %{with system_nvtt}
|
||||
rm -fr libraries/source/nvtt
|
||||
@ -225,7 +221,7 @@ export STRIP=/bin/true
|
||||
%files
|
||||
%doc README.txt
|
||||
%license LICENSE.txt
|
||||
%license license_gpl-2.0.txt license_lgpl-2.1.txt
|
||||
%license license_gpl-2.0.txt license_lgpl-2.1.txt license_mit.txt
|
||||
%{_bindir}/0ad
|
||||
%{_bindir}/pyrogenesis%{dbg}
|
||||
%{_libdir}/%{name}
|
||||
@ -236,6 +232,9 @@ export STRIP=/bin/true
|
||||
%{_mandir}/man6/*.6*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.0.22-1
|
||||
- Update to 0.0.22
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.21-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user