Update to latest upstream release

This commit is contained in:
pcpa 2013-09-05 13:55:00 -03:00
parent 24202a75a9
commit 3b32dda747
9 changed files with 221 additions and 250 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/0ad-0.0.13-alpha-unix-build.tar.xz
/0ad-0.0.14-alpha-unix-build.tar.xz

View File

@ -1,21 +0,0 @@
diff -up 0ad-0.0.13-alpha/build/premake/extern_libs4.lua.orig 0ad-0.0.13-alpha/build/premake/extern_libs4.lua
--- 0ad-0.0.13-alpha/build/premake/extern_libs4.lua.orig 2013-08-07 13:37:33.983209591 -0300
+++ 0ad-0.0.13-alpha/build/premake/extern_libs4.lua 2013-08-07 13:38:33.638211876 -0300
@@ -242,7 +242,7 @@ extern_lib_defs = {
-- The following are not strictly link dependencies on all systems, but
-- are included for compatibility with different versions of Boost
android_names = { "boost_filesystem-gcc-mt", "boost_system-gcc-mt" },
- unix_names = { "boost_filesystem-mt", "boost_system-mt" },
+ unix_names = { "boost_filesystem", "boost_system" },
bsd_names = { "boost_filesystem", "boost_system" },
})
end,
@@ -251,7 +251,7 @@ extern_lib_defs = {
link_settings = function()
add_default_links({
android_names = { "boost_signals-gcc-mt" },
- unix_names = { "boost_signals-mt" },
+ unix_names = { "boost_signals" },
bsd_names = { "boost_signals" },
})
end,

View File

@ -1,18 +1,18 @@
diff -up 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile.orig 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile
--- 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile.orig 2013-04-03 10:18:41.527414409 -0300
+++ 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile 2013-04-03 10:21:17.209420370 -0300
@@ -9,10 +9,7 @@ endif
CXX ?= g++
CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
diff -up 0ad-0.0.14-alpha/libraries/source/fcollada/src/Makefile.orig 0ad-0.0.14-alpha/libraries/source/fcollada/src/Makefile
--- 0ad-0.0.14-alpha/libraries/source/fcollada/src/Makefile.orig 2013-09-05 11:06:14.192030546 -0300
+++ 0ad-0.0.14-alpha/libraries/source/fcollada/src/Makefile 2013-09-05 11:09:01.894036968 -0300
@@ -14,10 +14,7 @@ CXXFLAGS += -fvisibility=hidden -W -Wall
ifeq ($(OS_CPU),armv7l)
CXXFLAGS += -mtune=cortex-a15 -mfpu=neon-vfpv4 -mfloat-abi=hard
endif
-CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
CXXFLAGS_RELEASE := -O1 -DNDEBUG -DRETAIL
-# (-O2 with gcc 4.3 causes linker errors when using this library, for unknown reasons, so stick with -O1)
-# (-O2 with gcc 4.3 causes linker errors when using this library, for unknown reasons, so stick with -O1 until gcc >4.3 is typical.)
-CXXFLAGS_TEST := -O0 -g -D_DEBUG
LIBS += `pkg-config libxml-2.0 --libs`
INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
@@ -181,72 +178,19 @@ SOURCE = \
@@ -186,62 +183,13 @@ SOURCE = \
FColladaPlugins/FArchiveXML/FAXSceneExport.cpp \
FColladaPlugins/FArchiveXML/FAXSceneImport.cpp \
@ -78,18 +78,17 @@ diff -up 0ad-0.0.13-alpha/libraries/source/fcollada/src/Makefile.orig 0ad-0.0.13
output/libFColladaSR.a: $(OBJECTS_RELEASE)
@echo "$@"
@ar -cr $@ $(OBJECTS_RELEASE); ranlib $@
@@ -250,8 +198,7 @@ output/libFColladaSR.a: $(OBJECTS_RELEAS
output/FColladaTest: $(OBJECTS_TEST)
$(CXX) -o $@ $(LDFLAGS) $(OBJECTS_TEST) $(LIBS)
-output/FColladaTest: $(OBJECTS_TEST)
- $(CXX) -o $@ $(LDFLAGS) $(OBJECTS_TEST) $(LIBS)
-
-install: output/libFColladaSD.a output/libFColladaSR.a
- cp output/libFColladaSD.a ../lib/libFColladaSD.a
+install: output/libFColladaSR.a
cp output/libFColladaSR.a ../lib/libFColladaSR.a
dfile = $(@:.o=.d)
@@ -256,18 +200,10 @@ gendep = \
@@ -261,18 +208,10 @@ gendep = \
sed -e 's/\#.*//' -e 's/^[^:]*: *//' -e 's/ *\\$$//' \
-e '/^$$/ d' -e 's/$$/ :/' < $(dfile) >> $(Pfile) && \
rm -f $(dfile)

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
diff -up 0ad-0.0.13-alpha/build/premake/premake4.lua.orig 0ad-0.0.13-alpha/build/premake/premake4.lua
--- 0ad-0.0.13-alpha/build/premake/premake4.lua.orig 2013-04-03 10:11:08.168397048 -0300
+++ 0ad-0.0.13-alpha/build/premake/premake4.lua 2013-04-03 10:13:06.433401577 -0300
@@ -313,26 +313,6 @@ function project_set_build_flags()
diff -up 0ad-0.0.14-alpha/build/premake/premake4.lua.orig 0ad-0.0.14-alpha/build/premake/premake4.lua
--- 0ad-0.0.14-alpha/build/premake/premake4.lua.orig 2013-08-26 23:42:56.000000000 -0300
+++ 0ad-0.0.14-alpha/build/premake/premake4.lua 2013-09-05 11:04:57.114027595 -0300
@@ -326,26 +326,6 @@ function project_set_build_flags()
defines { "INSTALLED_LIBDIR=" .. _OPTIONS["libdir"] }
end

View File

@ -1,6 +1,6 @@
diff -up 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp
--- 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 2013-04-03 10:15:59.888408219 -0300
+++ 0ad-0.0.13-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp 2013-04-03 10:16:13.753408750 -0300
diff -up 0ad-0.0.14-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 0ad-0.0.14-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp
--- 0ad-0.0.14-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp.orig 2013-09-05 11:13:07.035046355 -0300
+++ 0ad-0.0.14-alpha/source/tools/atlas/AtlasUI/ScenarioEditor/ScenarioEditor.cpp 2013-09-05 11:13:09.036046432 -0300
@@ -692,30 +692,20 @@ bool ScenarioEditor::OpenFile(const wxSt
void ScenarioEditor::OnOpen(wxCommandEvent& WXUNUSED(event))

4
0ad.6
View File

@ -1,7 +1,7 @@
.TH 0AD "1" "Apr 2 2013" "0ad 0.0.13" "User Commands"
.TH 0AD "6" "Sep 6 2013" "0ad 0.0.14" "User Commands"
.SH NAME
0ad \- manual page for 0ad 0.0.13
0ad \- manual page for 0ad 0.0.14
.SH SYNOPSIS
.B 0ad
[\fIoptions\fR]

View File

@ -24,8 +24,8 @@
%endif
Name: 0ad
Version: 0.0.13
Release: 8%{?dist}
Version: 0.0.14
Release: 1%{?dist}
# BSD License:
# build/premake/*
# libraries/valgrind/* (not built/used)
@ -116,9 +116,6 @@ Patch1: %{name}-saveas.patch
# It also prevents assumption there that it is building in x86
Patch2: %{name}-debug.patch
# Correct 0ad FTBFS (#991906)
Patch3: %{name}-boost-0.54.0.patch
%description
0 A.D. (pronounced "zero ey-dee") is a free, open-source, cross-platform
real-time strategy (RTS) game of ancient warfare. In short, it is a
@ -140,9 +137,6 @@ hobbyist game developers, since 2001.
# disable debug build, and "int 0x3" to trap to debugger (x86 only)
%patch2 -p1
%endif
%if 0%{?fedora} > 19
%patch3 -p1
%endif
%if %{with_system_nvtt}
rm -fr libraries/nvtt
@ -238,6 +232,9 @@ export STRIP=/bin/true
%{_mandir}/man6/*.6*
%changelog
* Thu Sep 5 2013 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.14-1
- Update to latest upstream release
* Wed Aug 7 2013 pcpa <paulo.cesar.pereira.de.andrade@gmail.com> - 0.0.13-8
- Make package x86_64 and ix86 only as arm support is not finished.

View File

@ -1 +1 @@
3075c982c4af41a3586b6b6ef637d2c4 0ad-0.0.13-alpha-unix-build.tar.xz
5bbaffa02b6e9082cbd5142d43f9b700 0ad-0.0.14-alpha-unix-build.tar.xz