Patched for new GCC and rebuilt for Boost 1.64
This commit is contained in:
parent
337000da6d
commit
18edb3cabf
11
0ad-abs-unsigned.patch
Normal file
11
0ad-abs-unsigned.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- 0ad-0.0.21-alpha/source/gui/CDropDown.cpp.orig 2017-07-17 18:52:09.775883922 +0100
|
||||
+++ 0ad-0.0.21-alpha/source/gui/CDropDown.cpp 2017-07-17 18:52:13.235881914 +0100
|
||||
@@ -345,7 +345,7 @@
|
||||
int diff = 0;
|
||||
for (size_t j = 0; j < m_InputBuffer.length(); ++j)
|
||||
{
|
||||
- diff = abs(pList->m_Items[i].GetOriginalString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
+ diff = abs((int)pList->m_Items[i].GetOriginalString().LowerCase()[j] - (int)m_InputBuffer[j]);
|
||||
if (diff == 0)
|
||||
indexOfDifference = j+1;
|
||||
else
|
8
0ad.spec
8
0ad.spec
@ -110,6 +110,9 @@ Patch3: %{name}-valgrind.patch
|
||||
# And other fixes
|
||||
Patch4: %{name}-mozjs-incompatible.patch
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1423200
|
||||
Patch5: %{name}-abs-unsigned.patch
|
||||
|
||||
%description
|
||||
0 A.D. (pronounced "zero ey-dee") is a free, open-source, cross-platform
|
||||
real-time strategy (RTS) game of ancient warfare. In short, it is a
|
||||
@ -132,6 +135,7 @@ hobbyist game developers, since 2001.
|
||||
%endif
|
||||
%patch3 -p0
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%if %{with system_nvtt}
|
||||
rm -fr libraries/source/nvtt
|
||||
@ -232,8 +236,8 @@ export STRIP=/bin/true
|
||||
%{_mandir}/man6/*.6*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 03 2017 Jonathan Wakely <jwakely@redhat.com> - 0.0.21-5
|
||||
- Rebuilt for Boost 1.64
|
||||
* Mon Jul 17 2017 Jonathan Wakely <jwakely@redhat.com> - 0.0.21-5
|
||||
- Patched for new GCC and rebuilt for Boost 1.64
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.21-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user